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12	 WORKING WITH MOBILE DESIGN	 B-2P	Note:  You will find 
this lesson on your 
Account page once you 
register your book, as 
described in “Accessing 
the lesson files and Web 
Edition.” 
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WORKING WITH CODE

Lesson overview
In this lesson, you’ll learn how to work with code and do the 
following:

•	 Write code using code hinting and Emmet shorthand.

•	 Set up a CSS preprocessor and create SCSS styling.

•	 Use multiple cursors to select and edit code.

•	 Collapse and expand code entries.

•	 Use Live Code view to test and troubleshoot dynamic code.

•	 Use Inspect mode to identify HTML elements and associated 
styling.

•	 Access and edit attached files using the Related Files interface.

This lesson will take about 90 minutes to complete. To get the lesson 
files used in this lesson, download them from the webpage for this book 
at www.adobepress.com/DreamweaverCIB2021. For more information, 
see “Accessing the lesson files and Web Edition” in the “Getting Started” 
section at the beginning of this book.

4
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Dreamweaver’s claim to fame is as a visually based 
HTML editor, but its code-editing features don’t take a 
back seat to its graphical interface, and they offer few 
compromises to professional coders and developers.
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Creating HTML code
As one of the leading WYSIWYG HTML editors, Dreamweaver allows users to 
create elaborate webpages and applications without touching or even seeing the 
code that does all the work behind the scenes. But for many designers, working 
with the code is not only a desire but a necessity.

Although Dreamweaver has always made it as easy to work with a page in Code 
view as it is in Design view or Live view, some developers believe that the code-
editing tools took a back seat to the visual design interface. Although in the past 
this was partially true, Dreamweaver CC (2021 release) is fully invested in the vastly 
improved tools and workflows for coders and developers that were brought to the 
program in the previous version. In fact, Dreamweaver can now unify your entire 
web development team as never before by providing a single platform that can 
handle almost any task.

You’ll often find that a specific task is actually easier to accomplish in Code view 
than in Live view or Design view alone. In the following exercises, you’ll learn more 
about how Dreamweaver makes working with the code an effortless and surpris-
ingly enjoyable task.

Writing code manually
As you complete this and the next eight lessons, you will have numerous opportu-
nities to view and edit code by hand. But for anyone jumping directly to this lesson, 
this exercise will provide a quick overview of the topic. One way to experience 
Dreamweaver’s code-writing and editing tools is to create a new file.

1	 Define a site based on the lesson04 folder downloaded from your account page, 
as described in the “Getting Started” section at the beginning of the book.

2	 Select Developer from the Workspace menu.

All the code-editing tools work identically in either workspace, but the Devel-
oper workspace focuses on the Code view window and provides a better experi-
ence for the following exercises.

P	Note:  If you have 
not already down-
loaded the project files 
for this lesson to your 
computer from your 
Account page, make 
sure to do so now. See 
“Getting Started” at the 
beginning of the book.

P	Note:  Some tools 
and options are avail-
able only when Code 
view is active.
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3	 Choose File > New.

The New Document dialog appears.

4	 Choose New Document > HTML > None. 
Click Create.

P	Note:  In all screen 
shots, we use the Classic 
color theme, which can 
be selected in Prefer-
ences. See the “Getting 
Started” section at the 
beginning of the book 
for more details.
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Dreamweaver creates the basic structure of a webpage automatically. The cursor 
will probably appear at the beginning of the code.

As you can see, Dreamweaver provides color-coded tags and markup to make it 
easier to read, but that’s not all. It also offers code hinting for ten different web 
development languages, including but not limited to HTML, CSS, JavaScript, 
and PHP.

5	 Choose File > Save.

6	 Name the file myfirstpage.html and save it in the lesson04 folder.

7	 Insert the cursor after the <body> tag. 
Press Enter/Return to create a new line. Type <

A code-hinting window appears, showing you a list of HTML-compatible codes 
you can select from.

8	 Type d

The code-hinting window filters to code elements that start with the letter d. 
You can continue to type the tag name directly or use this list to select the 
desired element. By using the list, you can eliminate simple typing errors.

9	 Press the Down Arrow key.

The dd tag in the code-hinting window is highlighted.

10	Continue pressing the Down Arrow key until the tag div is highlighted. 
Press Enter/Return.

P	Note:  Line breaks, 
indenting, and other 
whitespace is not 
required in HTML and 
is used only to make 
the code easier to read 
and edit. Sam
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The tag name div is inserted in the code. The cursor remains at the end of the 
tag name, waiting for your next input. For example, you could complete the tag 
name or enter various HTML attributes. Let’s add an id attribute to the div 
element.

11	Press the spacebar to insert a space.

The hinting menu opens again, displaying a different list; this time the list con-
tains various appropriate HTML attributes.

12	Type id and press Enter/Return.

Dreamweaver creates the id attribute, complete with equals sign and quota-
tion marks. Note that the cursor appears within the quotation marks, ready for 
your entry.

13	Type wrapper and press the Right Arrow key once.

The cursor moves outside the closing quotation mark.

P	 Note:  If your tag closed automatically, you can skip step 14.

14	Type ></

When you type the backslash (/), Dreamweaver closes the div element auto-
matically. As you see, the program can provide a lot of help as you write code 
manually. But it can help you write code automatically too.

15	Choose File > Save.

P	Note:  Depending 
on the settings in your 
program, tags may 
close automatically and 
you may have to move 
the cursor to complete 
the next step. This 
behavior can be turned 
off or adjusted in the 
Code Hints section of 
Preferences.

P	Note:  In HTML5, 
quotation marks are no 
longer required for tag 
attributes. However, 
older browsers and 
applications may 
not display the code 
properly without them. 
It does no harm to use 
them, so continue to 
add them to your code. 
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Writing code automatically
Emmet is a web-developer toolkit that was added to a previous version of 
Dreamweaver and enables you to supercharge your code-writing tasks. When you 
enter shorthand characters and operators, Emmet enables you to create whole 
blocks of code with just a few keystrokes. To experience the power of Emmet, try 
this exercise.

1	 If necessary, open myfirstpage.html.

2	 In Code view, insert the cursor within the div element and press Enter/Return 
to create a new line.

Emmet is enabled by default and works whenever you are typing in Code view. 
In the original site mockup, the navigation menu appears at the top of the page. 
HTML5 uses the <nav> element as the foundation of site navigation.

3	 Type nav and press Tab.

Dreamweaver creates the opening and closing tags all at once. The cursor 
appears inside the nav element, ready for you to add another element, some 
content, or both.

HTML navigation menus are usually based on an unordered list, which consists 
of a <ul> element with one or more child <li> elements. Emmet allows you 
to create multiple elements at the same time, and by using one or more opera-
tors, you can specify whether the subsequent elements follow the first (+) or are 
nested one within the other (>).

4	 Type ul>li and press Tab.

A <ul> element containing one list item appears. The greater-than symbol (>) 
is used to create the parent–child structure you see here. By adding another 
operator, you can create several list items.

5	 Choose Edit > Undo.

The code reverts to the ul>li shorthand. It’s easy to adapt this shorthand 
markup to create a menu with five items.
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6	 Edit the existing shorthand phrase as highlighted—ul>li*5—and press Tab.

A new unordered list appears, this time with five <li> elements. The asterisk 
(*) is the mathematical symbol for multiplication, so this latest change says 
“<li> times 5.”

To create a proper menu, you also need to add a hyperlink to each menu item.

7	 Press Ctrl+Z/Cmd+Z or choose Edit > Undo.

The code reverts to the ul>li*5 shorthand.

8	 Edit the existing shorthand phrase as highlighted: 
ul>li*5>a

If you guessed that adding the markup >a would create a hyperlink child ele-
ment for each link item, you are correct. Emmet can also create placeholder 
content. Let’s use it to insert some text in each link item.

9	 Edit the shorthand phrase as highlighted: 
ul>li*5>a{Link}

Adding text within braces passes it to the final structure of the hyperlink, but 
we’re not done yet. You can also increment the items, such as Link 1, Link 2, 
Link 3, and so on, by adding a variable character ($).

10	Edit the shorthand phrase as highlighted—ul>li*5>a{Link $}—and 
press Tab.

P	 Note:  The cursor must be outside the brace before you press Tab.
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The new menu appears fully structured, with five link items and hyperlink 
placeholders incremented 1 through 5. The menu is nearly complete. The only 
thing missing are targets for the href attributes. You could add them now using 
another Emmet phrase, but let’s save that change for the next exercise.

11	 Insert the cursor after the closing </nav> tag.

Press Enter/Return to create a new line.

Let’s see how easy it is to use Emmet to add a header element to your 
new page.

12	Type header and press Tab.

As with the <nav> element you created earlier, the opening and closing header 
tags appear, with the cursor positioned to insert the content. We will model the 
header after one you will use in Lesson 6, “Creating a Page Layout.” You need to 
add two text components: an <h2> for the company name and a <p> element 
for the motto. Emmet provides a method for adding not only the tags but also 
the content.

13	Type h2{Favorite City Tour}+p{Travel with a purpose} and 
press Tab.

The two elements appear complete and contain the company name and motto. 
Note how you added the text to each item using braces. The plus (+) sign desig-
nates that the <p> element should be added as a peer to the heading.

14	 Insert the cursor after the closing </header> tag.

15	Press Enter/Return to insert a new line.

As you can see, Emmet enables you to quickly build complex multifaceted 
parent–child structures like the navigation menu and the header, but it doesn’t 
stop there. As you string together several elements with placeholder text, you 
can even add id and class attributes. To insert an id, start the name with the 
hash symbol (#); to add a class, start the name with a dot (.). It’s time to push 
your skills to the next level.

P	Note:  Adding the 
new line makes the 
code easier to read and 
edit, but it has no effect 
on how it operates.

P	Note:  The entire 
phrase may wrap to 
more than one line in 
Code view, but make 
sure there are no spaces 
or line breaks within the 
markup.
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16	Type main#content>aside.sidebar1>p(lorem)^article> 
p(lorem100)^aside.sidebar2>p(lorem) and press Tab.

A <main> element is created with three child elements (aside, article, 
aside), along with id and class attributes. The caret (^) symbol in the short-
hand is used to ensure that the article and aside.sidebar2 elements are 
created as siblings of aside.sidebar1. Within each child element, you should 
see a paragraph of placeholder text.

Emmet includes a Lorem generator to create blocks of placeholder text auto-
matically. When you add lorem in parentheses after an element name, such as 
p(lorem), Emmet will generate 30 words of placeholder content. To specify 
a larger or smaller amount of text, just add a number at the end, such as 
p(lorem100) for 100 words.

Let’s finish up the page with a footer element containing a copyright 
statement.

17	 Insert the cursor after the closing </main> tag. 
Create a new line. 
Type footer{Copyright 2021 Favorite City Tour. 
All rights reserved.} and press Tab.

18	Save the file.

Using a few shorthand phrases, you have built a complete webpage structure and 
some placeholder content. You can see how Emmet can supercharge your code-
writing tasks. Feel free to use this amazing toolkit at any time to add a single ele-
ment or a complex, multifaceted component. It’s there anytime you need it.
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This exercise has barely scratched the surface of what Emmet can do. It is sim-
ply too powerful to fully describe in just a few pages. But you got a good peek at 
its capabilities.

Check out http://emmet.io to learn more about Emmet. Check out  
http://docs.emmet.io/cheat-sheet/ for a handy Emmet shorthand cheat sheet.

Working with multicursor support
Have you ever wanted to edit more than one line of code at a time? Another code-
editing feature in Dreamweaver CC (2021 release) is multicursor support. This 
feature allows you to select and edit multiple lines of code at once to speed up a 
variety of mundane tasks. Let’s take a look at how it works.

1	 If necessary, open myfirstpage.html as it appears at the end of the previous 
exercise.

The file contains a complete webpage with header, nav, main, and footer 
elements. The content features classes and several paragraphs of placeholder 
text. The <nav> element includes five placeholders for a navigation menu, but 
the href attributes are empty. For the menu and links to appear and behave 
properly, you need to add a filename, URL, or placeholder element to each link. 
The hash mark (#) is used as placeholder content until the final link destinations 
can be added.

Customizing the Common toolbar
Some of the code-editing exercises in this lesson require tools that may not appear in the interface by default. 
The Common toolbar was previously called the Coding toolbar and appeared only in Code view. The new tool-
bar appears in all views, but some tools may be visible only when the cursor is inserted directly in the Code view 
window.

If the exercise calls for a tool that is not visible, even with the cursor in the proper position, you may need to cus-
tomize the toolbar yourself. This can be done by first clicking the Customize Toolbar icon  and then enabling 
the tools within the Customize Toolbar dialog. At the same time, feel free to disable tools you don’t use.

Sam
ple

 p
ag

es

http://emmet.io
http://docs.emmet.io/cheat-sheet/
http://myfirstpage.html


ADOBE DREAMWEAVER CLASSROOM IN A BOOK (2021 RELEASE)  111

2	 Insert the cursor between the quotation marks in the href="" attribute in 
Link 1.

Normally, you would have to add a hash mark (#) to each attribute individually. 
Multicursor support makes this task much easier, but don’t be surprised if it 
takes you a little practice. Note that all the link attributes are aligned vertically 
on consecutive lines.

3	 Hold the Alt key (Windows) or Option key (macOS) and drag the mouse down 
through all five links.

Using the Alt/Option key enables you to select code or insert cursors in con-
secutive lines. Be careful to drag down in a straight line. If you slip a little to the 
left or right, you may select some of the surrounding markup. If that happens, 
you can just start over. When you are finished, you should see a cursor flashing 
in the href attribute for each link.

4	 Type # 
The hash mark (#) appears in all five attributes at the same time.

The Ctrl/Cmd key enables you to select code or insert cursors in nonconsecu-
tive lines of code.

5	 Hold the Ctrl/Cmd key and click to insert the cursor between the p and the > 
bracket in each of the three opening <p> tags in the <main> element.

6	 Press the spacebar to insert a space, and type class="first"

The attribute appears simultaneously in all three <p> tags.

7	 Save the file.

Multicursor support can save tons of time in repetitive code-editing tasks.
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Commenting your code
Comments allow you to leave notes within the code—invisible in the browser—to 
describe the purpose of certain markup or provide important information to other 
coders. Although you can add comments manually at any time, Dreamweaver has a 
built-in feature that can speed up the process.

1	 Open myfirstpage.html and switch to Code view, if necessary.

2	 Insert the cursor after the opening tag 
<aside class="sidebar1">.

3	 Click the Apply Comment icon .

A pop-up menu appears with several comment options. Dreamweaver supports 
comment markup for various web-compatible languages, including HTML, 
CSS, JavaScript, and PHP.

4	 Choose Apply HTML Comment.

An HTML comment block appears, with the text cursor positioned in 
the center.

5	 Type Insert customer testimonials into Sidebar 1

The comment appears in gray between the <!-- and --> markup. The tool can 
also apply comment markup to existing text.

6	 Insert the cursor after the opening tag 
<aside class="sidebar2">.

7	 Type Sidebar 2 should be used for content related to the tour 
or product

8	 Select the text created in step 7. 
Click the Apply Comment icon .

A pop-up menu opens.
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9	 Select Apply HTML Comment.

Dreamweaver applies the <!-- and --> markup to the selection. If you need to 
remove existing comment markup from a selection, click the Remove Comment 
icon  in the toolbar.

10	Save all files.

You’ve created a basic webpage complete with placeholder text. The next step is 
to style the page. Dreamweaver CC (2021 release) supports CSS preprocessors for 
LESS, Sass, and SCSS. In the next exercise, you’ll learn how to set up and create 
CSS styling using a preprocessor.

Working with CSS preprocessors
One of the biggest additions to Dreamweaver was support for LESS, Sass, and 
SCSS. These industry-standard CSS preprocessors are scripting languages that 
enable you to extend the capabilities of cascading style sheets with a variety of 
productivity enhancements that can then be compiled in a standard CSS file. These 
languages provide a variety of benefits for designers and developers who prefer to 
write their code by hand, including speed, ease of use, reusable snippets, variables, 
logic, calculations, and much more. No other software is needed to work in these 
preprocessors, but Dreamweaver also supports other frameworks, such as Compass 
and Bourbon.

In this exercise, you’ll get a taste of how easy it is use preprocessors with Dream-
weaver as well as what advantages they offer compared to a regular CSS workflow.

Enabling a preprocessor
Support for CSS preprocessors is site-specific and must be enabled for each 
site defined in Dreamweaver, as desired. To enable LESS, Sass, or SCSS, you 
first define a site and then enable the CSS Preprocessors option within the Site 
Definition dialog.

1	 Select Site > Manage Sites. 
The Manage Sites dialog appears.
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2	 Select lesson04 in the Manage Sites window. 
Click the Edit icon  at the bottom of the Manage Sites window.

The Site Definition dialog for lesson04 appears.

3	 Select the CSS Preprocessors option in the Site Definition dialog.

The CSS Preprocessors option contains six subcategories, including General, 
Source & Output, and options for various Compass and Bourbon frameworks. 
You can check out the Dreamweaver Help topics for more information on these 
frameworks. For this exercise, you need only the features that are built into the 
program itself.

4	 Select the General category.

When selected, this category features the on/off switch for the LESS, Sass, or 
SCSS compiler, as well as various options for how the languages operate. For 
our purposes, the default settings will work fine.

5	 Select the Enable Auto Compilation On File Save checkbox to enable the pre-
processor compiler, if necessary.Sam
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When this is enabled, Dreamweaver will automatically compile your CSS from 
your LESS, Sass, or SCSS source files whenever they are saved. Some designers 
and developers use the root folder of the site for compilation. In this case, we’ll 
separate the source and output files in distinct folders.

LESS or Sass—the choice is yours
LESS and Sass offer similar features and functions, so which one should you choose? 
That’s hard to say. Some think that LESS is easier to learn but that Sass offers more 
powerful functionality. Both make the chore of writing CSS by hand faster and easier 
and, more importantly, provide significant advantages for maintaining and extend-
ing your CSS over time. There are lots of opinions on which preprocessor is better, 
but you’ll find that it comes down to personal preference.

Before you decide, check out the following links to get some informed perspectives:

• 	 blog.udemy.com/less-vs-sass/

• 	 css-tricks.com/sass-vs-less/

• 	 keycdn.com/blog/sass-vs-less

Dreamweaver provides two syntaxes for Sass. In this lesson, we use SCSS (Sassy CSS), 
which is a form of Sass that is written like and looks more like regular CSS.

6	 Select the Source & Output category.

This category enables you to designate the source and output folders for your 
CSS preprocessor. The default option targets the folder where the source file 
is saved.

7	 Select the Define Output Folder option.

8	 Click the Browse For Folder icon .

A file browser dialog appears.

9	 Navigate to the Site Root folder, if necessary. 
Create a new folder.

Sam
ple

 p
ag

es

http://blog.udemy.com/less-vs-sass/
http://css-tricks.com/sass-vs-less/
http://keycdn.com/blog/sass-vs-less


116  LESSON 4  Working with Code

10	Name the new folder css. 
Click Create.

11	Select the css folder and click Select Folder/Choose.

12	Click the Browse For Folder icon  beside the Source Folder field.

13	Navigate to the Site Root folder.

Select the existing Sass folder, and  
click Select Folder/Choose.

14	Save the changes and click Done to return to your site.

The CSS preprocessor is enabled, and the source and output folders are now 
designated. Next, you’ll create the CSS source file.

Creating the CSS source file
When using a preprocessor workflow, you do not write the CSS code directly. 
Instead, you write rules and other code in a source file that is then compiled to the 
output file. For the following exercise, you’ll create a Sass source file and learn some 
of the functions of that language.

1	 Select Standard from the Workspace menu.

2	 Choose Window > Files to display the Files panel, if necessary.

Select lesson04 from the Site List dropdown menu, if necessary.
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3	 If necessary, open myfirstpage.html and switch to Split view.

The webpage is unstyled at the moment.

4	 Choose File > New.

The New Document dialog appears. This dialog allows you to create all types of 
web-compatible documents. In the Document Type section of the dialog, you 
will see the LESS, Sass, and SCSS file types.

5	 Choose New Document > SCSS. 
Click the Create button.

A new blank SCSS document appears in the document window. SCSS is a flavor 
of Sass that uses a syntax similar to regular CSS that many users find easier to 
learn and work with.

6	 Save the file as favorite-styles.scss in the Sass folder you targeted as the Source 
folder in the previous exercise.

There’s no need to create the CSS file; the compiler in Dreamweaver will do 
that for you. You’re all set to start working with Sass. The first step is to define 
variables. Variables are programmatic constructs that enable you to store CSS 
specifications you want to use multiple times, such as colors in your site theme. 
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By using a variable, you have to define it only once. If you need to change it in 
the future, you can edit one entry in the style sheet and all the instances of the 
variable will update automatically.

7	 Insert the cursor into line 2 of favorite-styles.scss. 
Type $logoyellow: #ED6; and press Enter/Return.

You’ve created your first variable. This is the main green color of the site theme. 
Let’s create the rest of the variables.

8	 Type $darkyellow: #ED0;  
$lightyellow: #FF3;  
$logoblue: #069; 
$darkblue: #089; 
$lightblue: #08A; 
$font-stack: "Trebuchet MS", Verdana, Arial, Helvetica,  
sans-serif;  
and press Enter/Return to create a new line.

Entering the variables on separate lines makes them easier to read and edit but 
does not affect how they perform. Just make sure you add a semicolon (;) at the 
end of each variable.

Let’s start the style sheet with the base or default styling of the body element. 
SCSS markup in most cases looks just like regular CSS, except in this case you’ll 
use one of your variables to set the font family.

9	 Type body and press the spacebar. 
Type { and press Enter/Return.

When you typed the opening brace ({), Dreamweaver created the closing brace 
automatically. When you created the new line, the cursor was indented by 
default, and pressing Enter/Return moved the closing brace to the following 
line. You can also use Emmet to enter the settings more quickly.
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10	Type ff$font-stack and press Tab.

The shorthand expands to font-family: $font-stack;.

11	Press Enter/Return to create a new line. 
Type c and press Tab.

The shorthand expands to color: #000;. The default color is acceptable.

12	Hold the Alt/Cmd key and press the Right Arrow key to move the cursor to the 
end of the current line of code.

13	Press Enter/Return to create a new line. 
Type m0 and press Tab.

The shorthand expands to margin: 0;, completing the basic styling for the body 
element. Before you save the file, this is a good time to see how preprocessors do 
their work.
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Compiling CSS code
You have completed the specifications for the body element. But you have not 
created the styling directly in a CSS file. Your entries were made entirely in the 
SCSS source file. In this exercise, you will see how the compiler that is built into 
Dreamweaver generates the CSS output.

1	 Display the Files panel, if necessary, and expand the list of site files.

The site consists of one HTML file and three folders: Sass, images, and css. 

2	 Expand the view of the css and Sass folders.

The Sass folder contains favorite-styles.scss and _base.scss. The css folder 
contains favorite-styles.css. This file did not exist when you started the lesson. 
It was generated automatically when you created the SCSS file and saved it into 
the site folder defined as the Source folder. At the moment, the CSS file should 
contain no CSS rules or markup. It’s also not referenced in the sample webpage.

P	Note:  The 
favorite‑styles.css 
file should have been 
created automatically 
in the previous exercise 
when the SCSS file was 
saved. If you do not see 
the .css file, you may 
need to shut down and 
relaunch Dreamweaver.
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3	 Select the document tab for myfirstpage.html. 
Select View > Split > Code-Live.

The page shows only default HTML styling.

4	 In the Code view window, insert the cursor after the opening <head> tag and 
press Enter/Return to insert a new line.

5	 Type <link and press the spacebar.

The hinting menu appears. You’ll link the webpage to the generated CSS file.

6	 Type href and press Enter/Return.

The complete href="" attribute appears, and the hinting menu changes to 
display the Browse command and a list of pathnames to folders available in 
the site.

7	 Press the Down Arrow key to select the path css/ and press Enter/Return.

The hinting menu now displays the path and filename to favorite-styles.css.
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