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4 EDITING AND COMBINING 
SHAPES AND PATHS

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Cut with the Scissors tool.

•	 Join paths.

•	 Work with the Knife tool.

•	 Outline strokes.

•	 Work with the Eraser tool.

•	 Create a compound path.

•	 Work with the Shape Builder tool.

•	 Work with Pathfinder effects to create shapes.

•	 Work with the Reshape tool.

•	 Edit strokes with the Width tool.

This lesson will take about 45 minutes to complete. To get the lesson 
files used in this chapter, download them from the web page for this 
book at www.adobepress.com/IllustratorCIB2021. For more information, 
see “Accessing the lesson files and Web Edition” in the Getting Started 
section at the beginning of this book.Sam
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Soon after you begin creating simple paths and 
shapes, you will most likely want to use them to 
create more complex artwork. In this lesson, you’ll 
explore how to edit and combine shapes and paths.
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114  LESSON 4  Editing and Combining Shapes and Paths

Starting the lesson
In Lesson 3, you learned about creating and making edits to basic shapes. In this 
lesson, you’ll take basic shapes and paths and learn how to edit and combine them 
to create artwork for a few dinosaur illustrations.

1	 To ensure that the tools function and the defaults are set exactly as described in 
this lesson, delete or deactivate (by renaming) the Adobe Illustrator preferences 
file. See “Restoring default preferences” in the “Getting Started” section at the 
beginning of the book.

2	 Start Adobe Illustrator.

3	 Choose File > Open. Locate the file named 
L4_end.ai, which is in the Lessons > 
Lesson04 folder that you copied onto 
your hard disk, and click Open. This file 
contains the finished artwork.

4	 Choose View > Fit All In Window; leave 
the file open for reference, or choose File > 
Close (I closed it).

5	 Choose File > Open. In the Open dialog 
box, navigate to the Lessons > Lesson04 
folder, and select the L4_start.ai file on 
your hard disk. Click Open.

6	 Choose File > Save As. If the Cloud 
Document dialog box opens, click Save On 
Your Computer to save it locally. 

7	 In the Save As dialog box, change the name 
to Dinosaurs.ai (macOS) or Dinosaurs 
(Windows), and choose the Lesson04 
folder. Leave Adobe Illustrator (ai) chosen from the Format menu (macOS) or 
Adobe Illustrator (*.AI) chosen from the Save As Type menu (Windows)  
and then click Save. 

8	 In the Illustrator Options dialog box, leave the Illustrator options at their default 
settings, and click OK.

9	 Choose Window > Workspace > Reset Essentials.

�	Note:  If you don’t see Reset Essentials in the Workspace menu, choose Window > Workspace > 
Essentials before choosing Window > Workspace > Reset Essentials.

�	Note:  If you 
have not already 
downloaded the project 
files for this lesson  
to your computer from 
your Account page, 
make sure to do so 
now. See the “Getting 
Started” section at the 
beginning of the book.

�	�	Tip:  By default, the 
.ai extension shows on 
macOS, but you can add 
the extension on either 
platform in the Save As 
dialog box.
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Editing paths and shapes
In Illustrator, you can edit and combine paths and shapes in a variety of ways 
to create your own artwork. Sometimes that may mean starting with simpler 
paths and shapes and using different methods to produce more complex paths. 
This includes working with the Scissors tool ( ), the Knife tool ( ), and the 
Eraser tool ( ); outlining strokes; joining paths; and more.

Cutting with the Scissors tool
There are several tools that allow you to cut and divide shapes. You’ll start with the 
Scissors tool ( ), which splits a path at an anchor point or on a line segment to 
create an open path. Next, you’ll cut a shape with the Scissors tool and reshape it.

1	 Click the View menu, and make sure that the Smart Guides option is selected.  
A checkmark appears when it’s selected.

2	 Choose 1 Dino 1 from the Artboard Navigation menu in the lower-left corner of 
the Document window. Choose View > Fit Artboard In Window to make sure 
the artboard fits in the document window.

3	 Select the Selection tool ( ) in the toolbar, and click the purple shape on the left 
side of the artboard.

4	 Press Command and + (macOS) or 
Ctrl and + (Windows) three times to zoom in 
to the selected artwork.

After you modify this shape, you’ll add it to 
the dinosaur head on the right side of the 
same artboard to complete the beak. 

5	 With the shape selected, in the toolbar press and hold on the Eraser 
tool ( ), and select the Scissors tool ( ). 

�	Note:  You’ll explore 
other methods for 
transforming artwork in 
Lesson 5.
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116  LESSON 4  Editing and Combining Shapes and Paths

6	 Move the pointer over the top edge of the shape, in the middle (see the first 
part of the following figure). When you see the word “intersect” and a vertical 
magenta line, click to cut the path at that point and then move the pointer away.

Cuts made with the Scissors tool must be somewhere on a line or a curve rather 
than on an end point of an open path. When you use the Scissors tool to click 
the stroke of a closed shape, like the shape in this example, the path is cut where 
you click so that it becomes an open path.

7	 Select the Direct Selection tool ( ) in the toolbar. Move the pointer over the 
selected (blue) anchor point and drag it up.

8	 From where you originally cut the shape, drag the other anchor point up and to 
the left until a magenta alignment guide shows, indicating it’s aligned with the 
other anchor point you just dragged.

Notice that the stroke (the yellow border) doesn’t go all the way around the 
shape. That’s because cutting a shape with the Scissors tool makes an open path. 
If you only want to fill the shape with a color, it doesn’t have to be a closed path. 
It is, however, necessary for a path to be closed if you want a stroke to appear 
around the entire fill area.

�	Note:  To learn more 
about open paths and 
closed paths, see the 
section “Working with 
basic shapes” in  
Chapter 3.
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Joining paths
Suppose you draw a “U” shape and later decide to 
close the shape, essentially joining the ends of the 
“U” with a straight path. If you select the path, you 
can use the Join command to create a line segment 
between the end points, closing the path. 

When more than one open path is selected, you can 
join them to create a closed path. You can also join 
selected end points of two separate paths. Next, you’ll join  
the ends of the path you just edited to create a closed shape again.

1	 Select the Selection tool ( ) in the 
toolbar. Click away from the path to 
deselect it and then click in the purple 
fill to reselect it.

This step is important because only one 
anchor point was left selected from the 
previous section. If you were to choose 
the Join command with only one anchor 
point selected, an error message would appear. By selecting the whole path, 
when you apply the Join command, Illustrator simply finds the two ends of the 
path and connects them with a straight line.

2	 Click the Join button in the Quick 
Actions section of the Properties panel. 

When you apply the Join command 
to two or more open paths, by default 
Illustrator first looks for and joins the 
paths that have end points located 
closest to each other. This process is 
repeated every time you apply the Join command  
until all paths are joined.

3	 In the Properties panel, change the 
stroke to 0 by clicking the down arrow 
icon until the stroke is removed. 

Next, you’ll round the corners on the  
top of the shape.

Open path Endpoints
joined

�	�	Tip:  If you wanted 
to join specific anchor 
points from separate 
paths, select the anchor 
points and choose 
Object > Path > Join 
or press Command+J 
(macOS) or Ctrl+J 
(Windows).

�	�	Tip:  In Lesson 6, 
you’ll learn about the 
Join tool ( ), which 
allows you to join 
two paths at a corner, 
keeping the original 
curve intact.
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118  LESSON 4  Editing and Combining Shapes and Paths

4	 Select the Direct Selection tool ( ) in the toolbar and drag across the top of the 
shape to select the top two anchors.

5	 Drag one of the corner radius widgets toward the center of the shape to round 
the corners.

6	 Choose Select > Deselect and then choose File > Save.

Cutting with the Knife tool
You can also use the Knife tool ( ) to cut vector artwork. Using the Knife tool, 
you drag across a shape, and instead of creating open paths, you end up with 
closed paths.

1	 Press the spacebar to access the Hand tool, and drag in the document window 
to see the green shape to the right.

2	 With the Selection tool ( ) selected, 
click the green shape.

Any objects selected will be cut by the 
Knife tool. If nothing is selected, it will 
cut any vector objects it touches.

3	 Click Edit Toolbar ( ) at the bottom 
of the toolbar. Scroll in the menu that 
appears and toward the bottom of the 
menu you should see the Knife tool ( ). 
Drag the Knife tool directly onto the 
Scissors tool ( ) in the toolbar. When 
the Scissors tool shows a highlight, release 
to add the Knife tool to the list of tools.

4	 Press the Escape key to hide the menu.
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5	 With the Knife tool now selected in the toolbar, move the Knife pointer ( ) 
above the selected shape. Drag in a “U” shape to cut into the shape.

6	 Choose Select > Deselect.

7	 Select the Selection tool ( ), and click the new shape on the top (see the  
following figure).

8	 Click the Fill color box in the Properties panel, make sure the Swatches option 
( ) is selected in the panel that appears, and click to select a darker green.  
I chose the color named Dark green.

9	 Choose Select > Deselect.

Cutting in a straight line with the Knife tool

By default, as you just saw, dragging across a shape with the Knife tool makes a 
free-form cut that is not straight. Next, you’ll see how to cut artwork in a straight 
line with the Knife tool to give the dinosaur head (the green shape) a highlight. 

1	 With the Selection tool ( ) selected, click the large light green shape.

2	 Select the Knife tool ( ). Move the pointer just above the top of the shape. 
Press the Caps Lock key to turn the Knife tool pointer into crosshairs ( ).

The crosshairs pointer is more precise and can make it easier to see exactly 
where you begin cutting.
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120  LESSON 4  Editing and Combining Shapes and Paths

3	 Press and hold Option+Shift (macOS) or Alt+Shift (Windows), and drag down 
all the way across the shape to cut it into two. Release the mouse button and 
then the keys.

4	 Press and hold Option (macOS) or Alt (Windows), and drag down from the 
top of the shape, down, at a slight angle, all the way across the shape to cut it 
into two. Release the mouse button and then the key. This way, you can cut in a 
straight line in any direction.

5	 Choose Select > Deselect.

6	 Select the Selection tool ( ), and click the middle shape you just created (see 
the first part of the following figure).

7	 Click the Fill color box in the Properties panel, make sure the Swatches option 
( ) is selected in the panel that appears, and click to select a lighter green.  

8	 Drag across all of the green shapes to select them.

9	 Click the Group button in the Quick Actions section of the Properties panel. 

�	Note:  Pressing the 
Option/Alt key keeps 
the cut straight. Adding 
the Shift key (Option/
Alt-Shift) constrains the 
cutting to a multiple 
of 45 degrees.
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10	 Press the Caps Lock key to turn off the pointer crosshairs.

Outlining strokes
A path, like a line, can show a stroke color but not a fill color by default. If you create a 
line in Illustrator and want to apply both a stroke and a fill, you can outline the stroke 
of a path, which converts it into a closed shape (or compound path). Next, you’ll outline 
the stroke of a line so you can erase parts of it in the next section to make the final part 
used to complete the first dinosaur.

1	 Press the spacebar to access the Hand tool and drag in the document window to 
see the purple circle to the right.

2	 With the Selection tool ( ) selected, click 
the path of the purple circle.

To erase part of the circle and make it 
look like a dinosaur frill, the circle will 
need to be a filled shape, not a path. For 
an example of what a frill looks like, see 
the figure at the start of the next section, 
“Using the Eraser tool.” You should also 
see a set of gray lines that look like the spokes of a wheel. Those are just guides 
used for erasing. They were created by duplicating a straight line several times, 
and individually rotating each line 30º from the last.

3	 Choose Object > Path > Outline Stroke. 

This creates a filled shape that is a closed 
path. Next, you’ll erase parts of the shape.
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122  LESSON 4  Editing and Combining Shapes and Paths

Using the Eraser tool
\

The Eraser tool ( ) lets you erase any area of your 
vector artwork. You can use the Eraser tool on 
paths, compound paths, paths inside Live Paint 
groups, and clipping content. Whatever artwork you 
select is the only artwork you will erase. If you leave 
all objects unselected, you can erase any object that 
the tool touches across all layers. Next, you’ll use 
the Eraser tool to erase part of the selected shape so 
it looks like a triceratops frill (see the figure).

1	 Press and hold down the mouse button on the 
Knife tool ( ), and select the Eraser tool ( ) in the toolbar.

\

2	 Double-click the Eraser tool ( ) in 
the toolbar to edit the tool properties. 
In the Eraser Tool Options dialog 
box, change Size to 30 pt to make the 
eraser larger. Click OK.

You can change the Eraser tool 
options, depending on your needs.

3	 Move the pointer above the selected 
purple circle. Between two guide lines, drag in a “U” shape to create a scallop. 

When you release the mouse button, part of the shape is erased, and the shape 
is still a closed path. To finish, you’ll erase the bottom of the circle shape.

4	 Repeat this around the circle as you see in the figure, leaving the bottom intact.

�	Note:  You cannot 
erase raster images, 
text, symbols, graphs, or 
gradient mesh objects.

�	�	Tip:  With the 
Eraser tool selected 
and nothing selected 
in the document, you 
could also click the Tool 
Options button at the 
top of the Properties 
panel to see the options 
dialog box.
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5	 Move the pointer as in the first part of the following figure. Drag back and forth 
across the bottom of the purple circle to erase it. 

Erasing in a straight line

You can also erase in a straight line, which is what you’ll do next.

1	 Press the spacebar to access the Hand tool, and drag in the document window 
to see the partially complete dinosaur to the right.

2	 With the Selection tool ( ) selected, 
click the cream-colored nose horn.

3	 Choose View > Zoom In a few times to 
see more detail.

4	 Double-click the Eraser tool ( ) to edit 
the tool properties. In the Eraser Tool 
Options dialog box, change Size to 20 pt to make the eraser smaller. Click OK.

5	 With the Eraser tool ( ) selected, move the pointer to where you see the red 
“X” in the first part of the following figure. Press the Shift key, and drag straight 
across to the right. Release the mouse button and then the Shift key.

If nothing is erased, try again. Also, it may look like you erased other parts of the 
shape, but if nothing else was selected, you didn’t. 

6	 Choose File > Save.
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124  LESSON 4  Editing and Combining Shapes and Paths

Assemble the first dinosaur
To complete the dinosaur you see, you’ll drag and position the artwork you have 
worked on to this point. 

1	 Choose View > Fit Artboard In Window.

2	 With the Selection tool ( ) selected, drag the purple shape onto the beak of  
the dinosaur. 

3	 Drag the green group of shapes onto the head (see the following figure). 

4	 Drag the purple frill onto the purple circle behind the head. 

5	 If the purple frill covers any of the artwork, click Arrange toward the bottom of 
the Properties panel and choose Send Backward a few times until it looks like 
the figure.

Creating a compound path
Compound paths let you use a vector object to cut a hole in another vector object. 
Whenever I think of a compound path, I think of a doughnut shape, which can be 
created from two circles. Holes appear where paths overlap. A compound path is 
treated like a group, and the individual objects in the compound path can still be 
edited or released (if you don’t want them to be a compound path anymore). Next, 
you’ll create a compound path to create some art for a dinosaur’s eyes.

1	 Choose 2 Dino 2 from the Artboard Navigation menu in the lower-left corner of 
the Document window.

2	 With the Selection tool ( ) selected, select the dark gray circle on the left, and 
drag it so it overlaps the larger yellow circle to its right.
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Smart Guides help you align the circles. You can also select the two circles and 
align them to each other using the Align options in the Properties panel.

3	 Drag across the gray circle and yellow circle to select both.

4	 Choose Object > Compound Path > Make, and leave the artwork selected.

You can now see that the dark gray circle has seemingly disappeared, and you 
can see through the yellow shape to the aqua background shape. The dark 
gray circle was used to “punch” a hole in the yellow shape. With the shape still 
selected, you should see “Compound Path” at the top of the Properties panel to 
the right.

5	 Drag the group of lines that is just to 
the right of the yellow shape, into the 
center of the yellow shape. The group of 
lines should be on top. If it isn’t, choose 
Object > Arrange > Bring To Front.

6	 Drag across the eye shapes to  
select them.

7	 Choose Object > Group.

8	 Choose Select > Deselect, and then choose File > Save.

�	�	Tip:  You can still 
edit the original shapes 
in a compound path 
like this one. To edit 
them, select each 
shape individually with 
the Direct Selection 
tool ( ), or double-
click the compound 
path with the Selection 
tool, to enter Isolation 
mode and select 
individual shapes.
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Combining shapes
Creating more complex shapes from simpler shapes can be easier than trying to 
create them with drawing tools like the Pen tool. In Illustrator, you can combine 
vector objects in different ways. The resulting paths or shapes differ depending on 
the method you use to combine the paths. In this section, you’ll explore a few of the 
more widely used methods for combining shapes.

Start by creating a shape
Before you can jump into combining shapes, you’ll create a triangle. Then you’ll 
combine it with a few other shapes that are already there. Those shapes will then 
become the last part of the dinosaur. Before creating the triangle, you’ll swap the fill 
and the stroke so that the fill becomes the stroke for the new shape you make.

1	 To swap the fill and the stroke of 
the shape so that the fill becomes 
the stroke, click the Swap Fill And 
Stroke option toward the bottom of 
the toolbar. 

Having a stroke on the shape, rather 
than a fill, will make it easier to see the 
gray guide path.

2	 Press and hold on the Rectangle tool 
and select the Polygon tool in the toolbar.

3	 To the right of the eye shapes, in the middle of the artboard, you’ll see a few 
yellow shapes. Starting in the center of the yellow circle, drag to create a 
polygon. While dragging, press the down arrow a few times until the shape has 
three sides (triangle). Drag until the shape is as wide as the gray triangle guide, 
press the Shift key to straighten it, and release the mouse button and then 
the key. 

4	 Drag the top edge of the triangle down to snap to the guide triangle, and drag 
the bottom bounding point up to snap to the same guide triangle.
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Working with the Shape Builder tool
The first method you’ll learn for combining shapes involves working with the  
Shape Builder tool ( ). This tool allows you to visually and intuitively merge, 
delete, fill, and edit overlapping shapes and paths directly in the artwork. Using the 
Shape Builder tool, you’ll create a more complex shape for another dinosaur head 
from a series of simpler shapes you create.

1	 Select the Selection tool ( ) and drag across the existing yellow paths and 
the shape you made. The guide path for the triangle is locked, so it won’t 
be selected.

2	 Change the stroke weight to 5 pt in the 
Properties panel. Change the stroke 
color to the color named Orange to 
make it easier to see.

To edit shapes with the Shape Builder 
tool ( ), they need to be selected. Using 
the Shape Builder tool, you will now 
combine, delete, and paint these simple 
shapes to create a single shape.

3	 Select the Shape Builder tool ( ) in the toolbar. Move the pointer off the left 
side of the shapes, and drag to the right. Release the mouse button to combine 
the shapes.

When you select the Shape Builder tool, the overlapping shapes are temporarily 
divided into separate objects. As you drag from one part to another, a red 
outline appears, showing you the resulting shape when the shapes are 
merged together. 
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�	�	Tip:  You can also press the Shift key and drag a marquee across a series of shapes to combine 
them. Pressing Shift+Option (macOS) or Shift+Alt (Windows) and dragging a marquee across 
selected shapes with the Shape Builder tool ( ) allows you to delete a series of shapes within 
the marquee.

Next, you’ll delete a few shapes. You may want to zoom in to the shapes.

4	 With the shapes still selected, hold down the Option (macOS) or Alt (Windows) 
key. Notice that, with the modifier key held down, the pointer shows a minus 
sign ( ). Click in the middle of the shape on the far left, not the stroke, to 
delete it. Zoom in if you need. Refer to the figure to see which shape to remove.

5	 Move the pointer below the shapes. Hold down the Option (macOS) or Alt 
(Windows) key and drag through the rest of the bottom shapes. Release the 
mouse button and then the key to remove those shapes.

6	 Option-drag (macOS) or Alt-drag (Windows) across the two curved paths to 
delete them. Refer to the figure to see what to remove.

�	Note:  When you 
position the pointer 
over the shapes, 
make sure you see the 
mesh within those 
shapes before clicking 
to delete.
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7	 Select the Selection tool. To swap the fill and the stroke of the shape so that 
the stroke becomes the fill, click the Swap Fill And Stroke option toward the 
bottom of the toolbar. 

Assemble the second dinosaur
To complete the second dinosaur, you’ll drag and position the artwork you have 
worked on to this point. 

1	 Choose View > Fit Artboard In Window.

2	 With the Selection tool ( ) selected, drag the yellow eye into place on the 
dinosaur and the orange shape onto the nose. Don’t worry about exact 
positioning. Leave the last orange shape selected.

3	 Choose View > Zoom In a few times to zoom in to the dinosaur.

4	 To arrange the orange shape behind the other artwork on the nose, click 
Arrange in the Properties panel and choose Send Backward as many times as 
necessary. I had to choose it three times.
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