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USING THE ROTO BRUSH TOOL

Lesson overview
In this lesson, you’ll learn how to do the following:

• Extract a foreground object from the background using the 
Roto Brush tool.

• Correct the segmentation boundary across a span of frames.

• Touch up a matte with the Re�ne Edge tool. 

• Freeze a matte across a clip.

• Replace a background.

• Animate properties for creative e�ects.

• Track a face in footage.

�is lesson will take about an hour to complete. If you haven’t already 
done so, download the project �les for this lesson from peachpit.com/
AfterE�ectsCIB2024, following the instructions in the Getting Started 
section under “Accessing the lesson �les and Web Edition.” 

9
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With the Roto Brush tool, you can quickly separate 
a foreground object from a background across many 
frames. You can achieve professional results in a frac-
tion of the time you’d spend performing the same 
task with traditional rotoscoping.

PROJECT:  WEB BANNER PROJECT:  WEB BANNER Sam
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222 LESSON 9 Using the Roto Brush Tool

About rotoscoping
When you draw or paint on the frames of a movie, you’re rotoscoping. For example, a 
common use of rotoscoping is to trace an object, using the path as a mask to isolate 
it from the background so you can work with it separately. You could draw masks, ani-
mate the mask paths, and then use the masks to de�ne a matte. (A matte is a mask 
used to hide part of an image so that another image can be superimposed.) While 
e�ective, this is a time-intensive, tedious process, especially if the object moves a 
great deal or the background is complex.

If a background or foreground object is a consistent, distinct color, you could use 
color keying to separate the object from the background. If the subject was shot 
against a green or blue background (green screen or blue screen), keying is usually 
much easier than rotoscoping. However, keying is less e�cient when you’re work-
ing with complex backgrounds.

�e Roto Brush tool in After E�ects, powered by an AI model, is much faster than 
conventional rotoscoping. You use the Roto Brush tool to de�ne the foreground 
and background elements. �en After E�ects creates a matte, and tracks the move-
ment of the matte over time. �e Roto Brush tool does much of the work for you, 
leaving only a little cleanup work to be done. 

Getting started
In this lesson, you’ll use the Roto Brush tool to isolate a bird and rock pool so you can 
replace the background. To �nish up the project, you’ll add an animated title. 

First, you’ll preview the �nal movie and set up your project.

1 Make sure the following �les are in the Lessons/Lesson09 folder on your hard 
disk, or download them from peachpit.com now:

• In the Assets folder: Chickadee.mov, Facetracking.mov, MillPond.mov

• In the Sample_Movie folder: Lesson09.mp4

2 Open and play the Lesson09.mp4 sample movie in Windows Movies & TV 
or QuickTime Player to see what you will create in this lesson. When you are 
done, close Windows Movies & TV or QuickTime Player. You may delete the 
sample movie from your hard disk if you have limited storage space.

When you begin this lesson, restore the default application settings for After E�ects. 
See “Restoring default preferences” on page 3.

3 Start After E�ects, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (macOS). In the Startup Repair Options dialog box, 
click Reset Preferences. 
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4 Click New Project in the Home window.

After E�ects opens to display an empty, untitled project.

5 Choose File > Save As > Save As.

6 In the Save As dialog box, navigate to the Lessons/Lesson09/
Finished_Project folder.

7 Name the project Lesson09_Finished.aep, and then click Save.

Creating the composition
You’ll import a footage �le and create a composition from it.

1 Click New Composition From Footage in the Composition panel.

2 Navigate to the Lessons/Lesson09/Assets folder, select the Chickadee.mov �le, and 
then click Import or Open.

After E�ects creates a composition 
named Chickadee, based on the settings 
in the Chickadee.mov �le. �e composi-
tion is two and one half seconds long, 
with a frame size of 1920 x 1080. �e 
movie �le was shot at a rate of 29.97 
frames per second. 

3 Choose File > Save to save the project 
so far.
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224 LESSON 9 Using the Roto Brush Tool

Creating a segmentation boundary
You use the Roto Brush tool to specify which parts of the clip are in the foreground 
and which are in the background. You add strokes to distinguish the two, and then After 
E�ects creates a segmentation boundary between the foreground and background.

Creating a base frame
To use the Roto Brush tool to isolate a foreground object, you start by adding strokes 
to a base frame to identify foreground and background areas. You can start on any 
frame in the clip, but in this exercise, you’ll use the �rst frame as the base frame. 
First, you’ll add the strokes that identify the bird and the rock pool as the fore-
ground objects.

1 Move the current-time indicator across the time ruler to preview the footage. 

2 Press the Home key to move the current-time indicator to the beginning 
of the time ruler.

3 Select the Roto Brush tool ( ) in the Tools panel.

You use the Roto Brush tool in the Layer panel, which you’ll open now.

4 Double-click the Chickadee.mov layer in the Timeline panel to open the clip in the 
Layer panel.
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5 Choose Fit from the Magni�cation Ratio pop-up menu at the bottom of the Layer 
panel if you don’t see the entire image clearly.

By default, the Roto Brush tool creates green foreground strokes. You’ll start by adding 
strokes to the foreground—the rock pool and the bird. Generally, it’s most e�cient 
to start with broad strokes and then use smaller brushes to re�ne the border.

6 Choose Window > Brushes to open the Brushes panel. Set up a hard round 
100-pixel brush. (You may need to resize the Brushes panel to see the options.)

When you’re drawing strokes to de�ne the foreground object, follow the skeletal 
structure of the subject. Unlike traditional rotoscoping, you don’t need to de�ne a 
precise boundary around the object. Start with broad strokes, and work down to small 
regions as After E�ects determines where the boundary is supposed to be.

7 Draw a green stroke horizontally across the rock pool.

Roto Brush tool properties appear in the E�ect Controls panel. In the Layer panel, 
a magenta outline identi�es the boundaries After E�ects created for the foreground 
object. After E�ects recognized only about half of the pool, because you initially 
sampled only a small area of the subject. You’ll help After E�ects �nd the boundary 
by adding some more foreground strokes. First, you’ll make sure you’re using ver-
sion 3 of the Roto Brush tool. 

▶Tip: You can quickly 
zoom in and out of 
the Layer panel using 
the scroll wheel on your 
mouse, if it has one.
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226 LESSON 9 Using the Roto Brush Tool

8 In the E�ect Controls panel, make sure 3.0 is selected for the Version.

9 Still using a large brush, continue to draw green strokes along the inside edges of 
the pool. Do not include the branches directly behind the pool and the bird.

10 Zoom to 200% and use the Hand tool ( ) to pan to the bird.

11 Select the Roto Brush tool again. �en select a smaller brush, and draw a green 
stroke across the bird’s body.

It can be tricky to get some areas without accidentally adding background as well. 
It’s okay if you haven’t captured every detail in the foreground. You’ll use back-
ground strokes to remove any extraneous areas of the matte.

12 Press Alt (Windows) or Option 
(macOS) to switch to the red 
background stroke brush. Add red 
strokes to background areas you 
want to exclude from the matte. 
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13 Switch back and forth between the foreground and background brushes and brush 
sizes to �ne-tune the matte. Don’t forget to deselect the branches directly behind 
the bird and the pool. In some cases, one click may be all it takes to exclude an 
object or area from the matte. 

14 When you’re happy with the bird’s matte, zoom back out and �ne-tune any 
remaining areas that need to be addressed with the rock pool.

Editing Adobe Premiere Pro 
clips with After E�ects
You can work with a clip in both Adobe Premiere Pro and After Effects, moving 
easily between the two applications as you edit your project. 

To edit an Adobe Premiere Pro clip in After Effects, do the following:

1 Right-click or Control-click the clip in Adobe Premiere Pro, and choose Replace 
With After Effects Composition. 

After Effects starts, and opens the Adobe Premiere Pro clip.

2 Save the project when you’re prompted by After Effects. Then, work in the 
composition just as you’d work in any other After Effects project. 

3 When you’re finished, save the project, and return to Adobe Premiere Pro. 

Your changes are automatically reflected in the timeline.
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228 LESSON 9 Using the Roto Brush Tool

Don’t worry about being exact about your brush strokes. Just make sure the matte 
is within 1 to 2 pixels of the edge of the foreground object. You’ll have an opportunity 
to re�ne the matte later. However, After E�ects uses the information on the base 
frame to adjust the matte for the rest of the span, so you want the matte to be accurate. 

15 Click the Toggle Alpha button ( ) at the bottom 
of the Layer panel. �e selected area is white 
against a black background, so you can see the 
matte clearly.

16 Click the Toggle Alpha Overlay button ( ) at 
the bottom of the Layer panel. �e foreground 
area appears in color, and the background has 
a red overlay.

17 Click the Toggle Alpha Boundary button ( ) at 
the bottom of the Layer panel to see the outline 
around the bird and rock pool again.

As you use the Roto Brush tool, the Alpha Boundary is the best way to see how 
accurate your boundary is, because you can see everything in the frame. However, 
the Alpha and Alpha Overlay options let you see your matte without the distraction 
of the background.

Re�ning the boundary across the span
You used the Roto Brush tool to create a base frame, which includes a segmentation 
boundary that divides the foreground from the background. �e Roto Brush span 
appears below the time ruler at the bottom of the Layer panel. When After E�ects 
has propagated the current boundary for a frame, the bar beneath that frame on the 
time ruler is green.

As you move forward and backward through the footage, the segmentation bound-
ary moves with the foreground object (in this case, the bird and the rock pool). 
You’ll step through the frames in the span and make adjustments to the segmentation 
boundary as necessary.

Because the rock pool is stationary, its track matte is consistent throughout the 
span. Given that, we’ll focus on the bird, which moves around a lot.
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1 Zoom in on the bird, and then make sure the Roto Brush tool is selected in the 
Tools panel. 

2 Press the 2 key on your main keyboard (not the numeric keypad) to move forward 
one frame.

Working from the base frame, After E�ects tracks the edge of the object and attempts 
to follow its movement. Depending on how complex your foreground and back-
ground elements are, the boundary may or may not conform exactly to the area you 
hoped it would. 

3 Using the Roto Brush tool, paint foreground and background strokes to re�ne the 
matte for this frame. If the matte is accurate, you don’t need to paint any strokes.

As you progress through this clip, you’ll notice changes to the segmentation bound-
ary with the bird’s beak. Likewise, you may need to re�ne the segmentation bound-
ary around the feet and legs.

▶Tip: To move 
forward one frame, 
press the 2 key on your 
keyboard; to move back 
one frame, press the 
1 key.

•Note: As it propa-
gates the segmentation 
boundary for a frame, 
After Effects caches that 
frame. Cached frames 
have a green bar in the 
time ruler. If you jump 
ahead to a frame 
further along the span, 
After Effects may take 
longer to calculate 
the boundary.
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4 Press the 2 key again to move forward to the next frame.

5 Use the Roto Brush tool to add to the foreground or subtract from the back-
ground as necessary to re�ne the boundary.

If you make a stroke you don’t like, you can always undo the stroke and try again. 
As you move through the span, each change you make a�ects the frames after it. 
�e more you re�ne your selection, the better the overall results will be. You may 
�nd it useful to move forward a few frames to see how changes a�ect the boundary.

When the bird is moving quickly (such as 0:14 –0:19), you’ll notice that the segmen-
tation boundary becomes more vague, but then “catches up” once the bird slows 
down again. When a frame displays rapid movement, focus on removing areas that 
should be excluded (such as the branch behind the bird), rather than adding blurry 
areas of the bird.

6 Repeat steps 4 and 5 until you reach the end of the layer.

7 Once you’re satis�ed with the bird, zoom out to �t the entire screen, and scroll 
though the span, making any adjustments as needed.

8 When you have completed re�ning the segmentation boundary for the entire 
layer, choose File > Save to save your work so far.
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Fine-tuning the matte
Roto Brush does a pretty good job, but there may be stray bits of background in the 
matte, or foreground areas that weren’t included. You’ll clean those up by re�ning 
the edge.

Adjusting the Roto Brush & Re�ne Edge e�ect
When you use the Roto Brush tool, After E�ects applies the Roto Brush & Re�ne 
Edge e�ect to the layer. You can modify the e�ect using settings in the E�ect 
Controls panel. You’ll use those settings to further re�ne the edge of the matte. 

1 Press the spacebar to play the clip in the Layer panel. Press the spacebar again 
to end the preview when you’ve seen the whole clip. 

As you preview the clip, you may notice that the segmentation boundary jumps 
around a bit. You’ll adjust the Reduce Chatter and Contrast settings to make it 
smoother.

2 In the E�ect Controls panel, decrease the Contrast to 40% and increase Reduce 
Chatter to 20%. 

�e Reduce Chatter value determines how much in�uence the current frame has 
when performing a weighted average across adjacent frames. Contrast a�ects how 
tight the boundary is. 

3 Preview the clip again. 
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Re�ne Soft Matte and 
Re�ne Hard Matte e�ects
After Effects includes two related effects for refining mattes: Refine Soft Matte and 
Refine Hard Matte. The Refine Soft Matte effect does the same thing as Refine Edge 
Matte, except it applies the effect to the entire matte at a constant width. If you 
need to capture subtle variations across an entire matte, use this effect.

The Refine Hard Matte effect performs the same edge refinements as the Roto Brush 
when Fine-Tune Roto Brush Matte is turned on in the Roto Brush & Refine Edge 
effect in the Effect Controls panel.

Using the Re�ne Edge tool
When an object isn’t smooth, the Roto Brush may not pick up the nuanced edge. 
�e Re�ne Edge tool lets you include �ne details such as wisps of hair in designated 
areas of the segmentation boundary. 

�ough it might be tempting to use the Re�ne Edge tool immediately after creat-
ing the base frame, it’s best to wait until you’ve re�ned the segmentation boundary 
across the entire clip. Because of the way After E�ects propagates the segmentation 
boundary, using the Re�ne Edge tool too early results in a matte that is di�cult to use.

1 Go to the base frame, which is the �rst frame of the clip, and then zoom in so 
that you can see the edges of the bird’s tail clearly. Use the Hand tool if necessary 
to move the layer so you can see the entire bird.

2 Select the Re�ne Edge tool ( ), hidden beneath the Roto Brush tool in the 
Tools panel.

�e tail is relatively soft, so a small brush size will work well. For a fuzzier object, 
you might have better results with a much larger brush. �e brush needs to overlap 
the stray edges that emerge from the object.

3 Change the brush size to 5 pixels. 

When you use the Re�ne Edge tool, draw strokes along the edges of the matte.

4 In the Layer panel, move the Re�ne Edge tool over the edge of the tail straddling 
the segmentation boundary and including the variations in the feathers. You can 
use multiple strokes if needed.
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When you release the mouse, After E�ects switches to the Re�ne Edge X-ray view 
so that you can see how the Re�ne Edge tool changes the matte, capturing the detail 
in the edges. 

5 Move the current-time indicator across the time ruler to view the edge. At 0:15, 
Re�ne Edge breaks away from the tail as the bird moves away rapidly. 

6 Change the brush size to 19 pixels.

7 At 0:15, press Alt (Windows) or Option (macOS) and erase the artifact from the 
Re�ne Edge tool, as it’s no longer useful going forward.

8 Continue to move forward and backward through the scene, applying the Re�ne 
Edge tool wherever the matte’s edge doesn’t capture the fuzziness of the bird’s 
feathers, and removing it wherever it strays from the tail.

9 Zoom out to see the entire scene, resize the Layer panel if you enlarged it, and then 
choose File > Save to save your work.

•Note: Use the 
Refine Edge tool only 
after you have cleaned 
up the matte across the 
entire clip.
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Freezing your Roto Brush tool results
You’ve put a fair amount of time and e�ort into creating the segmentation boundary 
across the entire clip. After E�ects has cached the segmentation boundary so it can 
recall it without having to make the calculations again. To keep that data easily 
accessible, you’ll freeze it. �is reduces the processing demands on your system 
so you can work faster in After E�ects.

Once the segmentation is frozen, you cannot edit it unless you unfreeze it. Refreezing 
the segmentation is time-consuming, so it’s best to re�ne the segmentation boundary 
as much as possible before freezing.

1 Click the Freeze button in the lower right area of the Layer panel. 

After E�ects displays a progress bar as it freezes the Roto Brush and Re�ne Edge tool 
data. Freezing may take a few minutes, depending on your system. As After E�ects 
freezes the information for each frame, the cache line turns blue. When it has �nished 
freezing, a blue warning bar appears above the time ruler in the Layer panel, remind-
ing you that the segmentation is frozen.

DDepending 
on your system, 
this may take 
a while.
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2 Click the Toggle Alpha Boundary button ( ) in the Layer panel to see the matte. 
�en click the Toggle Transparency Grid button ( ). Move the time marker across 
the time ruler to see the subject without the distractions of the background.

3 Click the Toggle Alpha Boundary button again to see the boundary.

4 Choose File > Save. 

After E�ects saves the frozen segmentation information with the project.

Changing the background
�ere are many reasons to isolate a foreground image from a background. You 
may want to replace the background entirely, moving the subject to a di�erent 
setting. Or you could simply want to change the foreground or background 
without modifying the other. In this lesson, you’ll remove the fenced in area of the 
background, and replace it with a di�erent background, which you’ll enhance with 
color correction tools.

1 Close the Layer panel to return to the Composition panel, and then move 
the current-time indicator to the beginning of the timeline. Choose Fit from 
the Magni�cation Ratio pop-up menu at the bottom of the Composition panel.

2 Hide the properties for the Chickadee.mov layer, if they’re visible.

�e Composition panel displays the composition, which includes only the 
Chickadee.mov layer, consisting only of the foreground you isolated from the clip. 

3 Click the Project tab to display the Project panel, and double-click an empty area 
in the Project panel. Navigate to the Lessons/Lesson09/Assets folder, select the 
MillPond.mov �le, and click Import or Open. 
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4 Drag the MillPond.mov clip from the Project panel to the Timeline panel, and 
place it below the original Chickadee.mov layer.

5 Click the new layer, press Enter or Return, and rename the layer Mill Pond 
Start. �en press Enter or Return again.

6 Select the Chickadee layer. �en, using the Selection tool ( ), drag the layer to 
the lower half of the Composition panel. Your values should be similar to ours.

7 Select the Mill Pond Start layer, and choose E�ect > Color Correction > 
Hue/Saturation.

You’ll use the Hue/Saturation e�ect in two di�erent ways, so you’ll create a duplicate 
layer for the second e�ect.

8 With the Mill Pond Start layer selected, choose Edit > Duplicate. Rename the 
bottom layer Mill Pond End. �en rename the top layer to remove the number 2 
from the name (so that its name is Mill Pond Start). 
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9 Select the Mill Pond Start layer, and then, in the E�ect Controls panel, do the 
following:

• Select Colorize.

• Change Colorize Hue to 56 degrees.

• Change Colorize Saturation to 19.

• Change Colorize Lightness to −25.

10 In the Properties panel, click the stopwatch icon for the Opacity value to create 
an initial keyframe at 100%.

11 Go to 1:10, and change the Opacity to 0.
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12 Still at 1:10, select the Mill Pond End layer.

13 In the E�ect Controls panel, click the stopwatch icon for the Channel Range 
property to create an initial keyframe.

14  Go to the end of the footage (2:25), and change the Master Hue to -30.

15 Press the spacebar to preview the project. Press the spacebar again when you’ve 
�nished.

�e background transitions from a monochromatic dusk to a full summer day and 
then again to the beginning of fall as the leaves change.

16 Choose File > Increment And Save. 

If you save incrementally, you can return to earlier versions of your project to make 
adjustments later. �is can be very useful if you’re experimenting or want to try 
alternative e�ects. �e Increment And Save feature preserves the previously saved 
version of the project and creates a new project with the same name, with an 
increasing number added to the �lename. 

Adding animated text
You’re nearly done. All you need to do is to add the animated title between the bird 
and the background. 

1 Deselect all layers, and then move the current-time indicator to the beginning 
of the time ruler.

2 Select the Type tool ( ), and then type Re�ections in the Composition panel.
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A new text layer named Re�ections appears in the Timeline panel at the top 
of the layer stack.

3 Select the Re�ections layer, and then do the following in the Text section 
of the Properties panel:

• Choose Courier New for the font.

• Choose Bold for the font style.

• Type 300 px for the font size.

• Choose Optical from the Kerning menu.

• Select white for the Fill color.

• Deselect the Stroke checkbox.

4 Click the More button, and then type 140% for the vertical scale.

5 Use the Selection tool ( ) to reposition the text to rest along the top edge of 
the rock pool, and then move the Re�ections layer below the Chickadee layer.

You’ll animate the text so that it appears on the screen in a liquid motion. 
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