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52

CREATING GRAPHICS 
AND TEXT

Lesson overview
In this lesson, you’ll learn how to do the following:

• Draw rectangles, ovals, and other shapes.

• Modify the shape, color, and size of drawn objects.

• Understand fill and stroke settings.

• Create and edit curves and variable-width strokes.

• Apply gradients and transparencies.

• Use the different paintbrushes for expressive drawing.

• Create and edit text, and use web fonts.

• Distribute objects on the Stage.

• Create and edit symbols.

• Apply filters to symbol instances.

This lesson will take about 3 hours to complete.

To get the lesson files used in this chapter, download them from the 
web page for this book at peachpit.com/AnimateCIB2024. For more 
information, see “Accessing the lesson files and Web Edition” in 
the Getting Started section at the beginning of this book.

2
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You can use rectangles, ovals, lines, and custom 
brushes to create interesting, complex graphics and 
save them as symbols, which will be displayed in your 
Library panel. Combine gradients, transparencies, text, 
and filters for even greater expressive possibilities.
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Getting started
Start by viewing the finished project to see what you’ll be creating in this lesson.

1 Double-click 02End.gif to view the image.

The project is a simple illustration consisting of an octopus character and a 
humorous caption. In this lesson, you’ll draw the shapes, modify them, and learn 
to combine simple elements to create more complex visuals. You won’t create 
any animation just yet. After all, you must learn to walk before you can run! And 
learning to create and modify graphics is an important step before doing any 
animation with Adobe Animate.

2 In the Animate Home screen, select More Presets or click Create New.

The New Document dialog box opens.

●Note If you 
have not already 
downloaded the project 
files for this lesson to 
your computer from 
your Account page, 
make sure to do so now. 
See Getting Started at 
the beginning of the 
book.
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3 Choose Advanced from the top row of categories. In the Platforms section, 
choose HTML5 Canvas. In the Details section, make the Stage size 1200 pixels 
by 800 pixels, and click Create.

4 Choose File > Save. Name the file 02_workingcopy.fla, and save it in the 02Start 
folder.

Saving your file right away is a good work habit (even if you’ve enabled the Auto-
Recovery feature). It ensures that you won’t lose your work if the application or 
your computer crashes.

Understanding strokes and fills
Every graphic created within Animate starts with a shape. A shape consists of two 
components: the fill, or the inside of the shape, and the stroke, or the outlines of the 
shape. If you always keep these two components in mind, you’ll be well on your way 
to creating beautiful and complicated visuals.

The fill and the stroke function independently of each other, so you can modify or 
delete one without affecting the other. For example, you can create a rectangle with 
a blue fill and a red stroke and then later change the fill to purple and delete the red 
stroke entirely; you’ll be left with a purple rectangle without an outline. You can also 
move the fill or stroke independently, so if you want to move the entire shape, make 
sure you select both its fill and its stroke.
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Creating shapes
Animate includes several drawing tools, which work in different drawing modes. 
Many of your creations will begin with simple shapes such as rectangles and ovals, 
so it’s important that you’re comfortable drawing them, modifying their appearance, 
and applying fills and strokes.

You’ll begin by drawing the face of the octopus.

Using the Oval tool
The eyes of the octopus are essentially a series of ovals overlapping one another. To 
make the eyes look angry, there is a diagonal line that cuts the largest oval at a slant. 
You’ll start by drawing the ovals. It’s useful to break down complicated objects into 
their component parts to make it easier to draw them.

1 Rename Layer_1 octopus.

2 In the Tools panel, select the Oval tool, which is hidden under the Rectangle 
tool. Hold down the Rectangle tool to access the Oval tool underneath. Make 
sure the Object Drawing button at the bottom of the Tools panel or in the 
Properties panel is not selected.

●Note In Animate, 
as well as in HTML 
documents and in 
web design and 
development in 
general, colors are 
often specified by 
hexadecimal numbers. 
The six digits after the 
# sign represent the 
red, green, and blue 
contributions to the 
color.
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3 Choose a stroke color and a fill color from the bottom of the Tools panel or 
from the Properties panel. Enter #CCCCCC (light gray) for the fill and #000000
(black) for the stroke.

4 On the Stage, draw an oval that is a little taller than it is wide.

5 Select the Selection tool.

6 Drag the Selection tool around the entire oval to select its stroke and its fill. When 
a shape is selected, Animate displays it with white dots. You can also double-click 
a shape, and Animate will select both the stroke and fill of the shape.

7 In the Properties panel, in the Position And Size section, enter 40 for the Width 
and 55 for the Height. Press Return (macOS) or Enter (Windows) to apply the values.
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Adding the inside of the eye
Now you’ll create the inside of the eye and the white highlight.

1 In the Tools panel, select the Oval tool.

2 Choose a stroke color and a fill color from the bottom of the Tools panel. Enter 
#000000 (black) for the fill and #000000 (black) for the stroke.

3 Draw a smaller black oval inside the larger oval on the Stage.

4 Enter #FFFFFF (white) as the fill for your Oval tool.

5 Draw a third oval at the top of your black oval, which will be the highlight.

Animate drawing modes
Animate provides three drawing modes that determine how objects interact 
with one another on the Stage and how you can edit them. By default, Animate 
uses Merge Drawing mode, but you can enable Object Drawing mode or use the 
Rectangle Primitive or Oval Primitive tool to use Primitive Drawing mode.

Merge Drawing mode

In this mode, Animate merges drawn shapes, such as rectangles and ovals, where 
they overlap so that multiple shapes appear to be a single shape. If you move or 
delete a shape that has been merged with another shape, the overlapping portion 
is permanently removed.

●Note The last fill 
and stroke you used 
are applied to the next 
objects you create, 
unless you change the 
settings before you 
draw.

▶ Tip Hold down 
the Shift key as you 
draw to constrain your 
shapes. Holding the 
Shift key when using 
the Oval tool creates 
perfect circles, much 
like holding the Shift 
key when using the 
Rectangle tool creates 
perfect squares.
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Object Drawing mode

In this mode, Animate does not merge drawn objects; they remain distinct and 
separate, even when they overlap. To enable Object Drawing mode, select the draw-
ing tool you want to use, and then click the Object Drawing button at the bottom of 
the Tools panel.

To convert an object to a shape (Merge Drawing mode), select the object and 
choose Modify > Break Apart (Command+B/Ctrl+B). To convert a shape to an object 
(Object Drawing mode), select the shape and choose Modify > Combine Objects 
> Union. The current shape becomes an object, but keep in mind that it doesn’t 
restore the shape to how it was originally drawn.

Primitive Drawing mode

When you use the Rectangle Primitive tool or the Oval Primitive tool, Animate 
draws your rectangles or ovals as independent objects that maintain some editable 
features. Unlike with regular objects, you can modify the corner radius and the start 
and end angles of rectangle primitives as well as adjust the inner radius of oval 
primitives using the Properties panel.

Making selections
To modify an object, you must first be able to select different parts of it. In 
Animate, you can make selections using the Selection, Subselection, and Lasso 
tools. Typically, you use the Selection tool to select an entire object or a section of 
an object. The Subselection tool lets you select a specific point or line in an object. 
With the Lasso tool, you can make a free-form selection.
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Selecting strokes and fills
Now you’ll refine the ovals to look more like an eye. You’ll use the Selection tool to 
delete unwanted strokes and fills.

1 In the Tools panel, select the Selection tool.

2 Double-click the stroke around the white oval.

The strokes around both the white oval and the black oval become selected.

3 Press the Delete/Backspace key.

The strokes are deleted, leaving behind a white oval as the highlight.

4 Choose the Line tool, and enter #000000 (black) as the stroke color.

5 Draw a diagonal line that cuts through the top of the eyeball.

The straight line creates intersecting shapes in the eyeball so that they can be 
selected separately.

6 Choose the Selection tool and click the half-dome gray shape at the tip of the eye.

7 Press the Delete/Backspace key.
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The gray fill is deleted.

8 Choose the curved stroke above the straight line and delete it.

One eye is finished!

Editing shapes
When drawing in Animate, you’ll often start with simple shapes such as rectangles, 
ovals, and lines. But to create more complex graphics, you’ll use other tools to 
modify those base shapes. The Free Transform tool, the Copy and Paste commands, 
and the Selection tool can help speed up your workflow.

Using Copy and Paste
Use the Copy and Paste commands to easily duplicate shapes on the Stage. Your 
octopus needs two eyes, so copying and pasting will come in handy.

1 Select the Selection tool, and drag it around the entire drawing of your eye.

2 Choose Edit > Copy (Command+C/Ctrl+C).

The eye is copied.

3 Choose Edit > Paste (Command+V/Ctrl+V).

A duplicate eye appears on the Stage. The duplicate remains selected.

4 Move the duplicate eye close to your original eye.

▶ Tip Use 
Paste In Place 
(Shift+Command+V/
Shift+Ctrl+V) if you 
want to paste the 
copied graphic in the 
exact same place where 
you copied it from.
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Using Free Transform
The duplicate eye needs to be flipped to make it look right. You’ll use the Free 
Transform tool to make it a mirror image of itself. You can also use the Free 
Transform tool to change an object’s scale, rotation, or skew (the way it is slanted), 
or to distort an object by dragging control points around a bounding box.

1 Choose Modify > Transform > Flip Horizontal.

The object flips, and you now have a right eye and a left eye.

2 Choose the Free Transform tool from the Tools panel.

Transformation handles appear on the eye.

3 Drag a corner point inward to make the left eye a little smaller. Hold down the 
Shift key while dragging to constrain the proportions so that the eye maintains 
the same aspect ratio.

4 Have fun making the second eye a little crazy. You can drag the corner points to 
squash or stretch an object or to rotate the object. You can also drag the sides of 
the bounding box to skew the object so that it appears slanted.

▶ Tip If you press 
the Option or Alt key 
while moving one of 
the control points, 
Animate scales the 
selected object relative 
to its transformation 
point, represented 
by the circle icon. 
You can move the 
transformation point 
anywhere, even outside 
the object. Press Shift 
to constrain the object 
proportions. Hold the 
Command/Ctrl key to 
distort the object from a 
single control point.

▶ Tip Hold the 
Command/Ctrl key to 
drag a single control 
point to distort the 
eyeball. If you press and 
hold Shift+Command/
Shift+Ctrl as you drag 
a corner point, you can 
move both corners 
the same distance 
simultaneously.
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Changing shape contours
With the Selection tool, you can push and pull lines and corners to change the over-
all contours of any shape. It’s a fast and intuitive way of working with shapes. You’ll 
use this technique to create the organic shape of the octopus head and body.

1 Insert a new layer on the timeline and name it body. Drag it so that it is below 
the octopus layer, which currently contains the eyes.

2 In the Tools panel, select the Oval tool. Choose a green color for the fill 
(#33CCCC) and black for the stroke.

3 Create three overlapping ovals, similar to the following figure, off to the side of 
the eyes. You don’t have to be exact here since you’ll edit these shapes.

4 Select the black outlines and press the Delete key.
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The black strokes are deleted.

5 Move your mouse cursor close to the side of one of the ovals.

A curved line appears near your cursor, indicating that you can change the 
curvature of the stroke.

6 Drag the stroke outward.

The side of the oval bends, giving the octopus head a slight bulge. Push and pull 
on the contours of the three ovals to create a more organic, bulbous head and 
natural-looking brow ridge for your octopus.

If you want to create a new corner point so that you can change the directions of 
a curve, hold down the Option/Alt key while you drag on the curve.
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Changing strokes and fills
If you want to change the properties of any stroke or fill, you can use the Ink Bottle 
tool or the Paint Bucket tool. The Ink Bottle tool changes stroke colors; the Paint 
Bucket tool changes fill colors. The check mark next to the quick key indicates the 
currently selected tool that is displayed in the Tool panel.

• Select the Paint Bucket tool and choose a new fill color in the Properties panel. 
Click a fill to change its color.

• Select the Ink Bottle tool (hidden under the Paint Bucket tool) and choose a new 
stroke color in the Properties panel. You can also choose the thickness and style 
of the stroke. Click a stroke to change its properties.

• You can also simply select a stroke or a fill on the Stage and change its properties 
by using the Properties panel.

Using variable-width strokes
You can make many different styles of lines for your strokes. In addition to the basic 
solid line, you can choose a dotted, dashed, or ragged line, or even customize your 
own. You can also create lines with variable widths and edit the variations with the 
Width tool.

Adding thick and thin outlines
The variable width of strokes can help give your drawings more expressive character.

1 Select the Ink Bottle tool, and in the Properties panel, choose 6 for the Stroke 
Size and Width Profile 1 for the Width.

▶ Tip If your Paint 
Bucket tool changes the 
fill in surrounding areas, 
there may be a small 
gap in the shape outline 
that allows the fill to 
spill over. Close the gap 
manually, or use the 
Gap Size menu at the 
bottom of the Tools 
panel to choose the gap 
size that Animate will 
close automatically.
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2 Click the large green octopus head.

Animate applies the thick-thin width profile to the outline of your green fill.

3 With the Selection tool, choose a single stroke segment around the green head, 
and then change the Stroke Size to 4.

Now you have two different stroke widths around your shape.

Stroke size of 4

Stroke size of 6
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4 Delete the stroke around the bottom oval shape. You’ll connect the octopus 
tentacles there, so you won’t need the black outline.

Refining variable-width lines
In addition to applying different width profiles to a stroke, you can customize where 
the bulges appear and how wide the bulges are with the Width tool.

1 Hold down the Shift key and click the three line segments of one of the eyebrows.

2 In the Properties panel, change the Stroke Size to 10.

3 Change the Width to Width Profile 1.

The straight line turns into a thicker line that is skinny on the ends and fatter in 
the middle, giving it a little more personality.

▶ Tip Edit variable-
width lines as you 
would any other stroke. 
Use the Selection or 
Subselection tool to 
bend the curves or 
move the anchor points.
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4 Click the three dots at the bottom of the Tools panel to edit the Toolbar.

5 Drag the Width tool from the Drag And Drop Tools panel to your Tools panel so 
that you can use it. Click off the Tools panel or press the Esc key to collapse it.

6 Move your mouse pointer over one of your variable-width strokes.

Anchor points appear along the line to show you where the thick and thin 
portions of the line are located.

▶ Tip To delete an 
anchor point of a 
variable-width line, click 
to select the anchor 
point and press Delete/
Backspace.
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7 Drag the handles at any anchor point to change the width of the line. Exaggerate 
some of the restrictions and bulges.

8 Drag an anchor point along the stroke to move its location.

9 Drag anywhere along the stroke to add a new anchor point and define the width 
at that location. Animate displays a small plus (+) sign next to your pointer to 
indicate that you can add an anchor point.

10 Modify both eyebrows of your octopus as you see fit, and apply a different width 
profile to the outline around the eyes as well.

Organizing your drawing
Now that you’ve finished creating the eyes and the head, you’ll want to start organiz-
ing the different parts of the drawing. You’ve already organized different shapes by 
putting them in separate layers, but you can also use groups to keep them separated.

Grouping objects
A group holds together a collection of shapes and other graphics to preserve their 
integrity. When the elements that compose the eyes are grouped, you can move 
them as a unit without worrying that the eyes might merge and intersect with 
underlying shapes in the same layer.

▶ Tip Hold down 
Option/Alt when you 
want to modify only 
one side of a variable-
width line.

Sam
ple

 p
ag

es


	Cover
	Title Page
	Copyright Page
	CONTENTS AT A GLANCE
	Contents
	2 CREATING GRAPHICS AND TEXT
	Getting started
	Understanding strokes and fills
	Creating shapes
	Making selections
	Editing shapes
	Using variable-width strokes
	Organizing your drawing

	INDEX
	A
	B
	C
	D
	E
	F
	G
	H
	I
	J
	K
	L
	M
	N
	O
	P
	Q
	R
	S
	T
	U
	V
	W
	X
	Z




