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GETTING ACQUAINTED

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Create a new file in Adobe Animate.

•	 Understand the different Animate document types.

•	 Adjust Stage settings and document properties and customize your 
workspace.

•	 Add layers using the Timeline panel.

•	 Understand and manage keyframes in the timeline.

•	 Work with imported images in the Library panel.

•	 Move and reposition objects on the Stage.

•	 Add filters and color effects to keyframes.

•	 Open and work with panels.

•	 Select and use tools in the Tools panel.

•	 Preview and publish your animation.

•	 Save your file.

This lesson will take less than 1 hour to complete.

To get the lesson files used in this chapter, download them from the 
web page for this book at www.adobepress.com/AnimateCIB2023. 
For more information, see “Accessing the lesson files and Web Edition” 
in the Getting Started section at the beginning of this book.
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9

In Animate, the Stage is where you lay out all your 
visual elements, the Timeline panel is where you 
organize frames and layers, and other panels let you 
edit and control your creation.
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10  LESSON 1  Getting Acquainted

Starting Adobe Animate and opening a file
The first time you start Adobe Animate you’ll see the Home screen, which also 
serves as a place to create a new document or open a saved document. It displays 
the kinds of projects you can build along with any recently opened files.

In this lesson, you’ll create a simple slideshow-type animation to showcase a few 
vacation snapshots. You’ll add a background, photos, and some decorative ele-
ments, and in the process you’ll learn about positioning elements on the Stage and 
placing them along the timeline of the animation so that they appear one at a time, 
in sequence. You’ll begin learning how to use the Stage to organize your visual 
elements spatially and how to use the Timeline panel to organize your elements 
temporally.

1	 Start Animate. In macOS, double-click Adobe Animate 2023 in the Adobe 
Animate 2023 folder in the Applications folder. In Windows, choose Start > 
Programs > Adobe Animate.

2	 Choose the Open button or choose File > Open (Command+O/Ctrl+O). In 
the Open dialog box, select the 01End.fla file in the Lesson01/01End folder and 
click Open to see the final project.

3	 Choose the Test Movie button in the upper-right corner of the application 
interface, or choose Control > Test.

Animate exports the project and opens it in a new window.

	$ Note   If you 
have not already 
downloaded the project 
files for this lesson to 
your computer from 
your Account page on 
peachpit.com, make 
sure to do so now. See 
Getting Started at the 
beginning of the book.

	▶�	 Tip   You can also 
start Animate by 
double-clicking an 
Animate file (*.fla or 
*.xfl), such as the 01End.
fla file that is provided 
to show you the 
completed project.
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ADOBE ANIMATE CLASSROOM IN A BOOK (2023 RELEASE)  11

An animation plays. During the animation, several overlapping photos appear 
one by one, with stars appearing at the end. As the new photos appear, the 
previous photos become blurry, receding into the background.

4	 Close the preview window and the FLA file.

Understanding document types 
and creating a new document
Animate is an animation and multimedia authoring tool that creates media for mul-
tiple platforms and playback technologies. Knowing where your final animation will 
play determines what type of document you’ll choose when you create a new file.

Playback environment
The playback, or runtime, environment is the technology that your final pub-
lished files use to play. Your animation could play in a browser with HTML5 and 
JavaScript. Perhaps your animation will be exported as a video to be uploaded to 
YouTube or an animated GIF on Twitter. Or your project could play as an app on a 
mobile device or even as a virtual reality immersive experience. You should make 
that decision first so that you can choose the appropriate document type.

	$ Note   Not all 
features are supported 
across all document 
types. For example, 
HTML5 Canvas 
documents don’t 
support the 3D Rotation 
or 3D Translation 
tools. Tools that are 
not supported by the 
current document type 
are dimmed in the 
Animate interface.
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12  LESSON 1  Getting Acquainted

Document types
There are nine types of documents, but you’ll likely work with only two or three of 
them, as they are the most common. The nine documents target different playback 
environments that determine some of the animation and interactivity features. Your 
choices for Animate documents are the following:

•	 Choose ActionScript 3.0 to create animation to export to video or to export 
graphics and animation assets, such as spritesheets or PNG sequences. 
ActionScript refers to the native scripting language in Animate, which is similar 
to JavaScript, but choosing an ActionScript 3.0 document doesn’t mean you have 
to include ActionScript code.

•	 Choose HTML5 Canvas to create projects that play back in a modern browser 
using HTML5 and JavaScript. You can add interactivity by inserting JavaScript 
within Animate or adding it to the final published files.

•	 Choose WebGL glTF Extended or WebGL glTF Standard for interactive 
animated assets to take advantage of hardware-accelerated support of graphics, 
or for supported 3D graphics.

•	 Choose AIR for Desktop to create animation and interactivity that plays as an 
application on Windows or macOS desktops, without needing a browser. You 
can add interactivity in an AIR document using ActionScript 3.0.

•	 Choose AIR for Android or AIR for iOS to publish an app for an Android 
or Apple mobile device. You can add interactivity to your mobile app using 
ActionScript 3.0.

•	 Choose VR Panorama or VR 360 to publish a virtual reality project for a web 
browser that lets your audience look in all directions. You can add animation or 
interactivity to your immersive environments.

Regardless of the playback environment and document type, all documents are 
saved as FLA or XFL (Animate) files. The difference is that each document type is 
configured to export different final published files.

Creating a new document
You’ll create the simple animation that you previewed earlier by starting a new 
document.

1	 Start at the Home screen in Animate, which is the default workspace when you 
launch the application. You can also get to the Home screen by pressing the 
Home button at the top left of the interface.

	$ Note   The 
ActionScript 3.0 
document also supports 
publishing content as 
a projector for either 
Windows or macOS. 
A projector plays as a 
stand-alone application 
on the desktop, without 
needing a browser.

	▶�	 Tip   You can easily 
switch from one 
document type to 
another. For example, 
you can convert 
an ActionScript 
3.0 document into 
an HTML5 Canvas 
document if you have 
an old Flash banner 
ad animation that you 
want to update. Choose 
File > Convert To > 
[new document type]. 
Some functionality 
and features may be 
lost in the conversion, 
however. For example, 
conversion to an HTML5 
Canvas document 
will comment out 
ActionScript code.
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ADOBE ANIMATE CLASSROOM IN A BOOK (2023 RELEASE)  13

The Home screen displays preset options for different playback environments 
and layout sizes.

For example, when you select More Presets and choose the Full HD option 
under Character Animation, Animate creates a new ActionScript 3.0 document 
meant to export video at 1920 pixels by 1080 pixels. The Square option under 
Ads creates a new HTML Canvas document at 250 pixels by 250 pixels meant for 
playback in a browser.

2	 Choose More Presets or choose Create New (File > New).

The New Document dialog box appears. The row at the top contains six categories 
of intended uses; click a category to display the preset size layouts it contains in the 
center of the dialog box. You can either use the presets as given or fine-tune their 
settings using the Details section on the right side of the dialog box.
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14  LESSON 1  Getting Acquainted

3	 Select the Advanced category at the far right.

The center of the dialog box now displays all the available platforms. You can 
select a document type and type your document’s dimensions into the Width 
and Height boxes.

4	 In the Platforms area in the center of the dialog box, select ActionScript 3.0. In 
the Details area on the right side of the dialog box, choose the dimensions of 
the Stage by entering new pixel values for the Width and Height. Enter 800 for 
Width and 600 for Height.

5	 Click Create.

Animate creates a new ActionScript 3.0 document with the specified Stage 
dimensions.

6	 Choose File > Save. Name the file 01_workingcopy.fla, and from the File 
Format/Save As Type menu, choose Animate Document (*.fla). Although the 
software application is called Animate, be aware that the file extension is .fla 
or .xfl, both of which preserve echoes of the name of the ancestor of Animate: 
Flash. Navigate to the 01Start folder and click Save.

Saving your file right away is a good working habit that ensures your work won’t 
be lost if the application or your computer crashes. You should always save 
your Animate file with the extension .fla (or .xfl if you save it as an Animate 
Uncompressed Document) to identify it as the Animate source file.

Getting to know the workspace
The first time you run Animate, you’ll be asked what kind of user you are—beginner 
or expert, for example. Your answer will determine how the interface is configured. 
Don’t worry about your choice, as you can customize your workspace to whatever 
makes you comfortable. You will also learn to configure the workspace to match 
how it appears in this book.

The Animate work area includes the command menus at the top of the screen and a 
variety of tools and panels for editing and adding elements to your movie. You can 
create all the objects for your animation in Animate, or you can import elements 
you’ve created in Adobe Illustrator, Adobe Photoshop, Adobe After Effects, or other 
compatible applications.

	$ Note   If you 
save your Animate 
document as an 
Animate Uncompressed 
Document (.xfl), your 
document is saved as 
a collection of files in 
folders and not as a 
single document. This 
exposes the contents of 
your document to you 
and to other developers 
to swap assets easily. 
The XFL format is a 
more advanced saved 
document that you 
won’t be using in this 
book.
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ADOBE ANIMATE CLASSROOM IN A BOOK (2023 RELEASE)  15

There are many different interface configurations, but in the Essentials workspace, 
Animate displays the menu bar, Timeline panel, Stage, Tools panel, Properties panel, 
and Edit bar, along with a few other panels. As you work in Animate, you can open, 
close, group, ungroup, dock, undock, and move panels around the screen to fit your 
work style or your screen resolution.

Layers

Edit bar
Application bar

Stage Properties panel

Tools panel

Timeline panel

Choosing a new workspace
Animate also provides a few preset panel arrangements (“workspaces”) that may 
better suit the needs of particular users. Use the Window > Workspaces submenu or 
the workspace switcher at the top right of the interface to choose a different work-
space or to save a new one.

1	 Click the workspace switcher and choose a new workspace.
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16  LESSON 1  Getting Acquainted

The various panels are rearranged and resized according to their importance in 
the chosen workspace. For example, the Animator and Designer workspaces put 
the Timeline panel at the top of the work area for easy and frequent access.

2	 Select the Essentials workspace.

This book shows the step-by-step lessons in the Essentials workspace. It provides 
a good balance of access to the Stage and the most commonly used panels.

3	 If you have moved some of the panels around and want to return to one of the 
prearranged workspaces, choose Window > Workspaces > Reset [preset name] 
and click Yes in the confirmation dialog box. Or, from the workspace switcher, 
choose the reset icon in front of the workspace name.

Saving your workspace
If you find an arrangement of panels that suits your style of work, you can save it as 
a custom workspace and return to it at a later date.

1	 Open the workspace switcher and enter a name for your new workspace in the 
field below New Workspace.

	$ Note   The default 
workspace is Basic if 
you state that you are 
a new user; otherwise, 
the default workspace is 
Essentials.
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ADOBE ANIMATE CLASSROOM IN A BOOK (2023 RELEASE)  17

2	 Click the Save Workspace icon next to the new name.

Animate saves the current arrangement of panels and adds it to the options in 
the Workspace menu, which you can access at any time.

3	 By default, the Animate interface is dark gray. However, you can change the 
interface to a lighter gray if you prefer. Choose Animate > Preferences > Edit 
Preferences (macOS) or Edit > Preferences (Windows), and in the General 
preferences category, choose a different level of gray.

In this book, the screenshots are shown in the Dark mode.

	▶�	 Tip   If you want to 
save and share your 
workspace preferences 
(in addition to other 
customizations), you 
can export them 
into an ANP file. 
Choose Animate > 
Preferences > Export 
Preferences to save a file 
that others can import.
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18  LESSON 1  Getting Acquainted

About the Stage
The big white rectangle in the middle of your screen is called the Stage. As with 
a theater stage, the Stage in Animate is the area that viewers see when a movie is 
playing. It contains the text, images, and video that appear on the screen. Move ele-
ments on and off the Stage to place them in and out of view. You can use the rulers 
(View > Rulers) or grids (View > Grid > Show Grid) to help you position items on 
the Stage.

Additional positioning aids include guides (pulled from the top or side rulers; View 
> Guides) and the Align panel, among others. You’ll learn about these tools in later 
lessons in this book.

By default, you’ll see the gray area off the Stage where you can place elements that 
won’t be visible to your audience. The gray area is called the pasteboard. To see only 
the Stage, choose View > Magnification > Clip To Stage to select the option. For 
now, leave Clip To Stage deselected, allowing the pasteboard to remain in view.

You can also click the Clip Content Outside The Stage button to crop the graphic 
elements that fall beyond the Stage area so that you can see how your audience will 
view your final project.

To scale the Stage so that it fits completely in the application window, choose View > 
Magnification > Fit In Window. You can also choose different magnification view 
options from the menu just above the Stage.

Changing the Stage properties
Now you’ll change the color of the Stage. The Stage color, along with document 
properties such as the Stage dimensions and frame rate, is available in the Properties 
panel, which is the vertical panel just to the right of the Stage.

1	 In the Document Settings section of the Properties panel, note that the 
dimensions of the current Stage (the Size parameters) are set at 800x600 pixels, 
which you chose when you created the new document.

	$ Tip   You can view 
the Stage in full-
screen mode without 
the distraction of 
the various panels 
by choosing View > 
Screen Mode > 
Full Screen Mode. Press 
F4 to toggle the panels, 
and press the Esc key 
to return to Standard 
Screen Mode.
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ADOBE ANIMATE CLASSROOM IN A BOOK (2023 RELEASE)  19

2	 Also in the Properties panel, click the Background Color box next to the Stage 
and choose a new color from the color palette. Choose dark gray (#333333).

Your Stage is now a different color. You can change the Stage properties at any time.

Working with the Library panel
The Library panel is accessible from a tab just to the right of the Properties panel. 
The Library panel displays the contents of your document’s library, which is where 
you store and organize symbols created in Animate, as well as warped assets and 
imported files, including bitmaps, graphics, sound files, and certain video clips. 
Symbols and warped assets are graphics used for animation.

About the Library panel
The Library panel lets you organize library items in folders, see how often an item 
is used in a document, and sort items by type. You can also create folders in your 
Library panel to help group items. When you import items into Animate, you can 
import them directly onto the Stage or into the library. However, any item you 
import onto the Stage is also added to the library, as are any symbols you create. You 
can then easily access the items to add them to the Stage again, edit them, or see 
their properties.

To display the Library panel, choose Window > Library, or press Command+L/Ctrl+L.

	$ Note   You’ll learn 
much more about 
symbols in Lesson 2, 
“Creating Graphics and 
Text.”

	▶�	 Tip   You can also 
save assets in the Assets 
panel (Window > 
Assets), or save them 
to share across Adobe 
products by storing 
them in your Creative 
Cloud account by 
clicking the CC Libraries 
icon (Window > 
CC Libraries).
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20  LESSON 1  Getting Acquainted

Importing an item to the Library panel
Often, you’ll create graphics directly with the drawing tools in Animate and save 
them as symbols, which are stored in the library. At other times you’ll use the Asset 
Warp tool to create a rig inside graphics, which are also stored in the library. You 
can also import media such as JPEG images or MP3 sound files, and they, too, are 
stored in the library. In this lesson, you’ll import several images into the library to be 
used in the animation.

1	 Choose File > Import > Import To Library. In the Import To Library dialog box, 
select the background.png file in the Lesson01/01Start folder and click Open. 
Choose All Files (*.*) from the Enable menu if the image files are dimmed.

Animate imports the selected PNG image and places it in the Library panel.

2	 Continue importing photo1.jpg, photo2.jpg, and photo3.jpg from the 01Start 
folder.

You can also hold down the Shift key to select multiple files and import all the 
images at once.

The Library panel lists the filenames of all the imported images and provides a 
thumbnail preview of any selected file. These images are now available to be used 
in your Animate document.

Adding an item from the Library panel to the Stage
To use an imported image, simply drag it from the Library panel onto the Stage.

1	 Choose Window > Library to open the Library panel if it isn’t already open.

	▶�	 Tip   If the Enable 
menu isn’t visible, click 
the Options button to 
activate it.

	▶�	 Tip   You can also 
choose File > Import > 
Import To Stage, or 
press Command+R/
Ctrl+R, to import an 
image file to the library 
and put it on the Stage, 
all in one step.
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ADOBE ANIMATE CLASSROOM IN A BOOK (2023 RELEASE)  21

2	 Drag the background.png item onto the Stage and place it approximately in the 
center of the Stage.

Understanding the Timeline panel
In the Essentials workspace, the Timeline panel is located below the Stage. The 
Timeline panel contains playback controls for your animation as well as the timeline 
itself, which displays the sequence of events in the animation from left to right. An 
Animate movie measures time in frames, just as in a filmstrip. As the movie plays, 
the playhead, shown as a blue vertical line, advances through the frames shown 
in the timeline. You can change the content on the Stage for different frames. To 
display a frame’s content on the Stage for any particular time, move the playhead to 
that frame in the timeline.

At the top of the Timeline panel, Animate indicates the selected frame number and 
the current frame rate (how many frames play per second).

Frame rate Current frame
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22  LESSON 1  Getting Acquainted

The timeline portion of the Timeline panel also displays layers, which help you orga-
nize the artwork in your document. At the moment, your project has only one layer, 
which is called Layer_1. Think of layers as multiple filmstrips stacked on top of one 
another. Each layer can contain a different image that appears on the Stage, and you 
can draw and edit objects on one layer without affecting objects on another layer. 
The layers are stacked in the order in which they overlap each other so that objects 
on the bottom layer in the timeline are on the bottom of the stack on the Stage. You 
can hide, lock, or show the contents of layers as outlines by clicking the dots or the 
square in the layer under the layer option icons.

If you have multiple layers, you can use the View Only Active Layer option above 
the timeline to show only the currently selected layer.

Changing the appearance of  
the timeline
You can adjust the timeline’s appearance to accommodate your workflow. When you 
want to see more layers, choose Short from the Frame View menu in the upper-right 
corner of the Timeline panel. The Short option decreases the height of frame cell 
rows. The Preview and Preview In Context options display thumbnail versions of the 
contents of your keyframes in the timeline.

Reset Timeline Zoom To The Default Level

Resize Timeline Zoom

For finer control over the timeline frame sizes, drag the Resize Timeline View slider. 
The slider adjusts the size of the frames so that you can see more or less of the 
timeline. Click the Reset Timeline Zoom To The Default Level button to revert the 
timeline view to its normal size.

To position different animation options on your timeline for quick access, click the 
options menu at the corner of the timeline and choose Customize Timeline Tools. 
The Customize Timeline menu appears, which contains all the available tools you 
can choose to display or to hide. The highlighted icons are those that are, by default, 
on the top of the timeline.
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ADOBE ANIMATE CLASSROOM IN A BOOK (2023 RELEASE)  23

Click to add or remove a tool. Click the Reset Timeline Controls button to reset the 
timeline to its original appearance.

Renaming a layer
It’s a good idea to separate your content on different layers and name each layer to 
indicate its contents so that you can easily find the layer you need later.

1	 Double-click the name of the existing layer, Layer_1, to rename it, and type 
background.

2	 Click outside the name box to apply the new name.

3	 Click below the lock icon to lock the layer. Locking a layer prevents you from 
accidentally moving or making changes to whatever is inside that layer.

A lock icon appears in the layer. The lock icon indicates that you can’t make edits 
to the layer because it is locked.
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24  LESSON 1  Getting Acquainted

Adding a layer
A new Animate document contains only one layer, but you can add as many layers 
as you need. Objects in the top layers will overlap objects in the bottom layers, 
unless you change the layer depth with the Layer Depth panel. You’ll learn more 
about this option in Lesson 7, “Animating the Camera.”

1	 Select the background layer in the timeline.

2	 Choose Insert > Timeline > Layer. You can also click the New Layer button above 
the timeline.

A new layer appears above the background layer.

3	 Double-click the new layer to rename it, and type photo1. Click outside the 
name box to apply the new name.

Your timeline now has two layers. The background layer contains the 
background photo, and the newly created photo1 layer above it is empty.

4	 Select the top layer, called photo1.

5	 Choose Window > Library to open the Library panel if it isn’t already open.

6	 Drag the library item called photo1.jpg from the library onto the Stage.

The photo1 image appears on the Stage and overlaps the background image.

7	 Choose Insert > Timeline > Layer, or click the New Layer button above the 
timeline, to add a third layer.

8	 Rename the third layer photo2.

	▶�	 Tip   As you add 
more layers and 
your overlapping 
graphics become more 
complicated, click the 
dot below the eye icon 
in any layer to hide its 
contents. Alternatively, 
hold Shift and click 
the dot below the eye 
icon to make the layer 
partially transparent 
so that you can see 
what’s below it. Hiding 
or making a layer 
transparent affects 
only how you see your 
project in Animate—it 
doesn’t affect your 
final exported project. 
Double-click the Layer 
icon to modify the 
level of transparency 
in the Layer Properties 
dialog box.
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Working with layers
If you don’t want a layer, you can easily delete it by selecting it and then clicking 
the Delete button above the timeline.

If you want to rearrange your layers and change how your graphics overlap 
each other, simply drag any layer up or down to move it to a new position in 
the layer stack.

Inserting frames
So far, you have a background photo and another overlapping photo on the Stage, 
but your entire animation exists for only a single frame, which is only a fraction of 
a second. To create more time on the timeline and make this animation run for a 
longer duration, you must add additional frames.

1	 Select frame 48 in the background layer. Use the Resize Timeline View slider at 
the upper-right corner of the Timeline panel to expand the timeline frames to 
make it easier to identify frame 48.

2	 Choose Insert > Timeline > Frame (F5). You can also choose Frame from the 
menu above the timeline or right-click frame 48 and choose Insert Frame from 
the context menu that appears.
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26  LESSON 1  Getting Acquainted

Animate adds frames in the background layer up to the selected frame, frame 48.

3	 Select frame 48 in the photo1 layer.

4	 Choose Insert > Timeline > Frame (F5), choose Insert Frame above the timeline, or 
right-click and choose Insert Frame to add frames in the photo1 layer up to frame 48.

5	 Select frame 48 in the photo2 layer and insert frames on this layer.

You now have three layers, all with 48 frames on the timeline. Since the frame rate of your 
Animate document is 24 frames per second, your current animation lasts 2 seconds.

Selecting multiple frames
Just as you can hold down the Shift key to select multiple files on your desktop, 
you can hold down Shift to select multiple frames on the Animate timeline. If you 
have several layers and want to insert frames into all of them, select a frame in 
the first layer and then Shift-click the same frame in the last layer to select all the 
frames in the layers in between, or drag to select multiple layers. Then choose 
Insert > Timeline > Frame.

Creating a keyframe
A keyframe indicates a change in content on the Stage. Keyframes are indicated on 
the timeline as a circle. An empty circle means there is nothing in that particular 
layer at that particular time. A filled-in black circle means there is something in that 
layer at that time. The background layer, for example, contains a filled keyframe 
(black circle) in the first frame. The photo1 layer also contains a filled keyframe in 
its first frame. Both layers contain photos. The photo2 layer, however, contains an 
empty keyframe in the first frame, indicating that it is currently empty.

Empty keyframe Filled keyframe
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Understanding Auto Keyframe mode
There are two modes for creating keyframes. The Auto Keyframe option above your 
timeline can be either enabled or disabled.

If it is enabled (the keyframe icon displays a letter “A”), adding or editing content on 
the Stage automatically creates a new keyframe at that point in time. If it is disabled, 
you create keyframes manually, as described in this task. Generally, for the projects 
in this book, you’ll want to keep the Auto Keyframe option disabled. This way, you 
will learn to create a keyframe only when you specifically want one, and you will 
avoid accidentally creating keyframes.

In the next task, you’ll insert a keyframe in the photo2 layer at the point in time 
when you want the next photo to appear.

1	 Make sure the Auto Keyframe option is off. Select frame 24 on the photo2 layer. The 
frame number of a selected frame is displayed above the left end of the timeline.

2	 Choose Insert Keyframe from the menu above the timeline, or choose Insert > 
Timeline > Keyframe (F6).

A new keyframe, indicated by an empty circle, appears in the photo2 layer in 
frame 24.

3	 Drag photo2.jpg from your library onto the Stage.

The empty circle at frame 24 becomes filled, indicating that there is now content 
in the photo2 layer. When your animation plays, your photo appears on the 
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