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3
Managing Photos 
in the Organizer

Digital photography can be a double-edged 
sword. Ironically, its greatest advantage to 
the amateur photographer—the ability to 
quickly and easily capture a large number 
of images, and then instantly download 
them to a computer—can also be its great-
est source of frustration. Once hundreds of 
images have been downloaded, photog-
raphers find themselves faced with the 
daunting task of sorting through myriad 
files, with incomprehensible filenames, 
to find those dozen or so “keepers” to 
assemble into an album or post online 
for friends.

The Organizer workspace comes to the 
rescue with a set of tools and functions 
to help you locate, identify, and organize 
your photos.

Because we need some source material 
to work with, this chapter jumps right into 
importing photos from a digital camera 
and opening images already on your 
hard disk.

In This Chapter
Import Images 28

Understand the Organizer Work Area 34

Work in the Media Browser 36

Rate Photos 38

Review Photos Full Screen 39

Use Stacks to Organize Similar Photos 40
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Filter Photos 65
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28 Chapter 3: Managing Photos in the Organizer

Import Images
Often, digital cameras come with their own 
software to help you browse and manage 
photos—but don’t bother. Access your 
camera from within Photoshop Elements 
and then import your images from the 
camera, or copy  photos first to your hard 
drive and then open them in the Organizer.

To import images from a digital 
camera (Standard dialog):
1. Connect your digital camera to your 

com puter using the instructions pro-
vided by the camera manufacturer, or 
connect a card reader containing the 
camera’s memory card.

If the Photo Downloader launches 
automatically, skip to step 3. If you 
don’t see the Photo Downloader, con-
tinue to step 2.

2. If you’re in the Home screen or in the 
Editor, click the  Organizer button to 
launch the  Organizer.

If you’re in the Organizer already, click 
Import and choose From Camera Or 
Card Reader (FIGURE 3.1). You can also 
choose File > Get  Photos And Videos, 
or press Ctrl+G/Command+G.

The Photo Downloader dialog opens 
in its Standard mode (FIGURE 3.2). For 
more importing options, see “To import 
images from a digital camera (Advanced 
dialog),” just ahead in this chapter.

3. Your camera or card will likely be 
selected in the Get Photos From menu, 
but if not, choose it.

Listed below the menu are the number 
of pictures, and their combined size.

FIGURE 3.1 Choose From Camera Or Card Reader 
to download photos from your digital camera.

FIGURE 3.2 The Photo Downloader’s Standard 
dialog makes it easy to import all photos in one 
fell swoop.
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Import Images 29

4. By default, the Photo Downloader 
saves images to your  Pictures folder; 
hold your pointer over the path listed 
next to Location to view the full destina-
tion if it’s truncated.

If you want to save the files to a 
different location, click the Browse 
(Windows)/Choose (macOS) button and 
select a folder or create a new one. 
Then click OK.

5. By default, the Photo Downloader 
creates new subfolders to store each 
batch of imported images, named 
according to the shot dates. From the 
Create Subfolder(s) menu, you can cus-
tomize this behavior by choosing one 
of the following options:

	f None saves the files in the folder 
specified by Location, normally your 
My Pictures folder.

	f Custom Name creates a folder with 
a name that you enter (FIGURE 3.3).

	f Today’s Date automatically creates a 
folder named with the current date.

	f Shot Date creates folders with the 
date the images were captured; 
choose your preferred date format 
from one of the options (FIGURE 3.4).

6. Choose an option from the Rename 
Files menu to automatically name the 
imported files something more descrip-
tive than what your camera assigns.

For example, your camera’s default 
naming scheme is probably something 
like IMG_1031.JPG. With a Rename 
Files option selected, you can name 
and number a set of photos “Vacation,” 
for instance. Then your photos will be 
saved and named Vacation001.jpg, 
Vacation002.jpg, and so on.

continues on next page

FIGURE 3.3 To make it easier to find images on disk 
later, specify a custom name for subfolders.

FIGURE 3.4 Choose a date format for naming 
 subfolders with the images’ capture dates.

Where the Image Files Exist
To keep track of the images in your 
library, the Organizer creates a catalog, 
typically located in the Pictures folder 
on your computer. When you import 
photos into your library, the image files 
are saved in the same location as the 
catalog. See “Work with Catalogs,” later 
in this chapter, for more information.
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30 Chapter 3: Managing Photos in the Organizer

7. In the Delete Options area, choose 
what happens to the files on the 
memory card. Just to be safe, I recom-
mend leaving the option set to After 
Copying, Do Not Delete Originals, and 
then erase the card in-camera later.

In the Windows version of the Organizer, 
the Automatic Download option is useful 
if you want to offload pictures onto the 
computer without going through the 
Photo Downloader. Images download 
automatically when a camera or other 
device is attached. You can turn it off 
later in the Organizer’s preferences.

8. Click Get Media to download the 
selected images to your computer.

Your photos first appear in their own 
Organizer window. Click the Back but-
ton (which sometimes reads All Media, 
depending on context) to return to the 
main Organizer window (FIGURE 3.5).

To import images from a digital 
camera (Advanced dialog):
1. Follow steps 1 through 8 in the 

 previous sequence, but in step 2 click 
the Advanced Dialog button to view 
the Advanced options (FIGURE 3.6).

2. Click to deselect the box under any 
photos you do not want to import. By 
default, the Organizer assumes you 
want to download every image.

3. In the Advanced Options area, choose 
to enable or disable the following 
(FIGURE 3.7):

	f Automatically Fix Red Eyes attempts 
to find and correct red eye problems 
in your photos as they’re downloaded.

	f Automatically Suggest Photo Stacks 
groups similar photos together for 
easy organization and review later 

FIGURE 3.5 Photos downloaded from the camera 
or memory card appear in the Organizer.

To view your entire photo library, 
click the Back button.

FIGURE 3.6 Preview all photos on your camera 
before importing them in the Advanced dialog (the 
left side of the window is shown here).
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Import Images 31

(see “Use Stacks to Organize  Similar 
Photos,” later in this chapter).

	f Automatically Stack Raw And JPEG 
pairs both image files captured when 
your camera is set to Raw+JPEG.

	f Import into Album assigns the photos 
to a photo album you’ve previously 
set up (see “Use Albums to Arrange 
and Group Photos,” later in this 
chapter).

4. Type your name (or the name of who-
ever took the photos) and a copyright 
notice in the Apply Metadata fields. 
This text is embedded in the image 
files (but not visible in the image itself).

5. To rotate an image as it’s imported, 
select it and click the Rotate Left or 
Rotate Right button at the lower-left 
corner (FIGURE 3.8).

 For a fast way to select just a few photos 
for import, first click the UnCheck All button, 
and then click the photos you want—don’t 
worry about clicking their individual boxes. 
Then, with the images selected, click just one 
box to enable the boxes of your selections.

 The Organizer can import photos 
stored in cameras’ Raw formats, which are 
the unprocessed versions of the captured 
images. Raw enables more adjustment pos-
sibilities than JPEG (which is processed and 
compressed in the camera). When you edit 
the photo in the Editor, it first opens in the 
Camera Raw dialog to set initial edits before 
continuing in the Editor. For more informa-
tion, see Chapter 9.

 The contents of the Creator and Copy-
right metadata fields are applied to all photos 
imported in that batch. If you want different 
authors, for example, either import them in 
several batches or edit the metadata after 
they’ve been added to the catalog.

FIGURE 3.8 Rotate images during import so you 
won’t have to do it later.

Rotate buttons

FIGURE 3.7 Further customize the importing 
process in the Advanced dialog (right side of 
window here).
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32 Chapter 3: Managing Photos in the Organizer

To import images from 
files or folders:
1. In the Organizer, click Import and 

choose From Files And Folders.

In Windows, if you insert media that 
contains photos, you may be asked 
what action you’d like to take (if you 
haven’t specified it already). Click the 
icon labeled Organize And Edit Adobe 
Elements 2022 Organizer, which opens 
a dialog to locate files.

2. Select the files you want to import 
(FIGURE 3.9); Shift-click to select a 
consecutive range of files, or Ctrl-click/
Command-click to select nonconsecu-
tive files.

3. If the images are stored on removable 
media and you want to import only low-
resolution versions, disable the Copy 
Files On Import option and enable the 
Generate Previews option (see the 
sidebar for more information).

4. As in the Advanced dialog mentioned 
on the previous pages, select from the 
processing options below the preview.

5. Click the Get Media button to import 
the photos. If the photos already 
include keyword tags, you have the 
option to import them.

 Now that we’ve gotten those import 
steps out of the way and you understand 
what’s going on, here’s a much quicker 
method: Simply drag image files from a folder 
on your hard disk to the Organizer’s window. 
Elements imports them without fuss.

 If you know some photos exist on your 
hard disk but can’t find them, let the Orga-
nizer hunt for them instead. Click the Search 
button in the upper-right corner and enter 
criteria about them.

FIGURE 3.9 Import images from other areas of your 
hard disk or from removable media.

Working with Offline Images
With removable media, you have the 
option of importing just a low-resolution 
file to the hard disk. This feature can 
save hard disk space, especially if lots 
of files are stored on a shared network 
drive or on several CDs or DVDs. Import-
ing them as offline images allows you to 
view and track your entire media catalog.

Offline images are designated with 
an icon in the upper-left corner of the 
image in the Organizer (FIGURE 3.10). 
You can apply tags, build collections, 
and perform other tasks. However, if you 
want to edit the image, the Organizer 
asks you to connect the original media. 
If it’s not available, you can still edit the 
low-resolution proxy, but the results 
won’t look good. Once you make the 
original available again, Elements copies 
the source image to your catalog as an 
online image.

FIGURE 3.10 
Offline images 
are denoted by a 
corner icon.

Offline icon
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To import images using Watch Folders:
1. You can specify one or more fold-

ers that the Organizer watches in the 
background for new files. Choose File > 
Watch Folders.

2. Click Add and navigate to the folder you 
wish to watch (FIGURE 3.11). Repeat for as 
many folders as you’d like.

3. Select an action under When New 
Files Are Found In Watched Folders; 
the Organizer can notify you when files 
are found or add them to the library 
automatically.

4. Click OK when you’re done.

5. When you add photos to your watched 
folder, you’re asked if you want to 
import them (if you opted to be notified 
in step 3). Click Yes to add the photos, 
which are moved from the watched 
folder to the directory where the Orga-
nizer stores your catalog.

To scan an image into the 
Organizer (Windows only):
1. Connect a scanner to your computer 

using the instructions provided by the 
scanner manufacturer.

2. In the Organizer, click the Import but-
ton and choose From Scanner. Or, you 
can choose File > Get Photos And Vid-
eos > From Scanner (or press Ctrl+U).

3. Choose your scanner software from 
the Scanner menu.

4. Select an image format and quality 
level.

5. Click OK. The Organizer hands off the 
actual scanning duties to the scanner’s 
software for you to complete the scan.

6. When you complete the scan and exit 
the scanner’s software, the image is 
imported into your catalog.

FIGURE 3.11 The Organizer can keep an eye on 
one or more folders and automatically import 
photos when they’re added.

VIDEO 3.1  

Work with HEIC/HEIF 
Images in Windows

Remove or Stop Watched Folders
Watched folders can be helpful, but 
they’re enabled by default. As a result, 
the Watch Folders dialog always inter-
rupts what I’m doing. You can remove a 
folder from the list of watched items, or 
turn off the feature entirely.

To remove a folder, choose File > Watch 
Folders, select the item in the list, and 
click Remove.

To turn off the feature, deselect Watch 
Folders And Their Sub-Folders for New 
Files.
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34 Chapter 3: Managing Photos in the Organizer

Understand the 
Organizer Work Area
The Organizer is dominated by the Media 
Browser, which is used to find and view 
thumbnail representations of your photos. 
It’s flanked by two panels that you use 
to group and organize your image files 
(FIGURE 3.12); the panels can be hidden to 
make room for more photos.

The Media Browser
Every digital photo or video downloaded 
into the Organizer is automatically added 
to the Media Browser. Resizable thumb-
nails in the Media Browser window make it 
easy to scan through even a large number 
of images.

Media is usually organized by the dates 
the photos or videos were captured, but 
you can also view images grouped by the 
people in them, by places where they’ve 
occurred (using geotagging information 
embedded in the files or locations you’ve 
specified on a map), or by time-based 
events. I cover each mode in this chapter.

The Folders panel
The panel at left includes multiple ways to 
display an overview of your image collec-
tion. Clicking Albums shows the albums 
you’ve created (discussed later in this chap-
ter), and clicking Folders reveals where the 
files are stored on disk (FIGURE 3.13). Click a 
folder name to view its contents.

You can also click the button at the top-
right corner of the Folders panel to expose 
your disk’s structure as a list or in a Tree 
view that reveals the folder hierarchy 
(FIGURE 3.14). In this view, for example, you 
can move images between disks (which 
ensures that the Organizer properly keeps 
track of them).

FIGURE 3.12 The Organizer workspace makes it 
easy to browse your entire photo collection.

FIGURE 3.13 The My Folders list reveals directories 
where your imported photos are located.

FIGURE 3.14 The Tree view shows folders in their 
hierarchies on disk.
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Understand the Organizer Work Area 35

To move folders in the Tree view:
1. Choose View As Tree from the button 

at the top right of the Folders panel.

2. Drag a folder to a new location 
(FIGURE 3.15).

Or

Select images in the Media Browser 
and drag them to a folder.

The folders and their files are moved in 
the Explorer (Windows) or Finder (macOS), 
not just in the Organizer.

The timeline
An optional, but helpful, way to quickly 
navigate your photos by date is the 
timeline, located just above the Media 
Browser. Choose View > Timeline or press 
Ctrl+L/Command+L. The timeline uses 
date and time information embedded 
in each image to construct bars (month 
markers) to represent sets of photos taken 
within specific months and years. When a 
month marker is selected in the timeline, 
that month’s  photos are displayed at the 
top of the Media Browser (FIGURE 3.16).

FIGURE 3.16 Click a month marker in the timeline 
to view that month’s photos on the Media Browser.

FIGURE 3.15 Move photos or folders using the 
Folder Hierarchy List.
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36 Chapter 3: Managing Photos in the Organizer

Work in the  
Media Browser
Throughout this chapter I’ll cover a variety 
of ways to work in the Media Browser to 
label, identify, and organize your photos. 
But first it’s important to know how best 
to select, sort, and display the image 
thumbnails.

To select photo thumbnails:
Do one of the following:

 ¡ Click to select a thumbnail in the Media 
Browser. The frame around it becomes 
light blue and gains a checkmark, 
indicating the thumbnail is selected 
(FIGURE 3.17).

 ¡ Ctrl-click/Command-click to select 
nonconsecutive thumbnails at once 
(FIGURE 3.18).

 ¡ Shift-click to select a group of consecu-
tive thumbnails (FIGURE 3.19).

 ¡ Choose Edit > Select All, or press 
Ctrl+A/Command+A to select every 
thumbnail in the Media Browser.

To deselect photo thumbnails:
Do one of the following:

 ¡ Ctrl-click/Command-click to deselect a 
single thumbnail.

 ¡ Choose Edit > Deselect, or press 
Ctrl+Shift+A/Command+Shift+A to 
deselect every thumbnail in the 
Media Browser.

 You can tweak the appearance of the 
Media Browser. Choose View > Details to 
reveal information such as grid lines, file-
names,  ratings, and timestamps (FIGURE 3.20).

FIGURE 3.17 A selected thumbnail appears with a 
light blue frame around it and a box.

FIGURE 3.20 When you choose to view details, the 
Media Browser gives each photo more space and 
displays additional information.

FIGURE 3.18 Ctrl-click/Command-click to select 
thumbnails that are not consecutive.

FIGURE 3.19 Shift-click to select thumbnails that 
are consecutive.
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Work in the Media Browser  37

To sort photo thumbnails:
 ¡ From the Sort By menu above the 

Media Browser, choose a sorting option 
(FIGURE 3.21):

	f Newest displays the most recent 
photos at the top, based on the 
images’ creation dates.

	f Oldest displays photos chronologi-
cally, with the oldest at the top.

	f Name sorts images in ascending 
alphabetical order based on their 
filenames. To make the names vis-
ible, choose View > Details, and then 
choose View > File Names.

	f Import Batch groups photos into 
the batches they were imported in 
(FIGURE 3.22).

To resize photo thumbnails:
 ¡ Below the Media Browser, drag the 

Zoom slider to the right to increase the 
size of the thumbnails, or to the left to 
make them smaller (FIGURE 3.23).

 ¡ Click the far left of the Zoom slider to 
display the thumbnails at their smallest 
possible size.

 ¡ Click the far right of the Zoom slider to 
display just one large photo thumbnail at 
a time (also known as Single Photo view).

 Double-click any thumbnail to change 
to Single Photo view. Double-click the image 
again to return to the Grid view.

FIGURE 3.21 Select an option to sort thumbnails in 
the Media Browser.

FIGURE 3.22 When you select the Import Batch 
option, the Media Browser displays thumbnails in 
grouped batch sets.

FIGURE 3.23 When you drag the Zoom slider to 
the right, the thumbnails grow larger (top). When 
you drag the slider to the left, they become smaller 
(bottom). VIDEO 3.2 

Essential Organizer 
Techniques
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38 Chapter 3: Managing Photos in the Organizer

Rate Photos
The number one method I use to organize 
my photos is rating them. By applying 
star ratings, I determine the shots that 
are worth keeping, the ones I want to edit 
later, and the ones I’m ready to share with 
others. Pairing ratings with other metadata, 
such as events for example, I can immedi-
ately view the best photos captured during 
a particular vacation or holiday.

To rate a photo:
 ¡ In the Media Browser, with View > 

Details enabled, click the gray stars 
that appear below a photo to set a rat-
ing from 1 to 5 (FIGURE 3.24).

 ¡ Select one or more images and click 
the stars under one of the photos to 
apply the same rating to them all.

 ¡ Select one or more images and press 
a number key between 1 and 5 corre-
sponding to the rating you want to apply.

 Star ratings are arbitrary—assign any 
value you like—but in general a 5-star rating 
indicates an excellent photo, while 1 star sug-
gests one that is barely passable. The scale 
that I personally use works like this: A 1-star 
rating means the image is fine—often not 
exciting, but not out of focus or immediately 
worth deleting. A 2-star rating is for photos 
that show promise during my initial review; 
usually I’ll revisit these photos during editing. 
A 3-star rating is for images that have been 
edited to my satisfaction. A 4-star or 5-star 
rating is reserved for photos that I think stand 
out above others.

 I know it’s tempting to jump straight to 
editing, but I recommend taking a few minutes 
to do a quick rating pass on your photos after 
you’ve imported them. Doing so makes it 
easier to pick out which ones to work on first.

Mark Photos as Hidden
If some photos seem to be cluttering 
up the Media Browser, use the Hidden 
attribute to keep them out of sight until 
you need them. Select a photo and 
choose Edit > Visibility > Mark As  Hidden 
(or press Alt+F2/Option+F2) to make the 
image disappear from view.

To view hidden photos, choose Edit > Vis-
ibility and choose either Show All Files or 
Show Only Hidden Files. An eye icon with 
a strikethrough mark appears on the face 
of each hidden photo’s thumbnail. Hide 
them again by choosing Edit >  Visibility > 
Hide Hidden Files.

To make a hidden file permanently  visible 
again, choose Edit > Visibility > Mark As 
Visible, which removes the attribute.

FIGURE 3.24 Apply a rating to identify your higher-
quality photos.

Sam
ple

 p
ag

es



Review Photos Full Screen 39

Review Photos 
Full Screen
When you’re looking over a set of photos, 
you want to see the photos, not everything 
else around them. The full-screen reviewing 
option lets you see just your images, with a 
minimal set of controls for ranking and sort-
ing, and even for applying basic edits.

To review photos full screen:
1. Choose View > Full Screen, or press 

Ctrl+F11/Command+F11. If you have a 
photo selected, it fills the screen; if not, 
the first item in your library appears 
(FIGURE 3.25).

2. Use the navigation controls at the 
 bottom of the screen to switch 
between files, play a slideshow, or hide 
or show the Quick Organize and Quick 
Edit  panels (FIGURE 3.26).

3. Use the Quick Organize panel to apply 
keyword tags and create new tags: 
click tag names in the Keyword Tags 
field to apply them.

You can also use the Quick Edit panel 
to make basic adjustments if you’re in 
a hurry.

4. Press Esc or click the Exit button to 
leave full-screen mode when you’re 
finished reviewing.

 Click the tiny pushpin icon on a panel to 
toggle between the panel remaining visible 
and automatically retracting to the edge of 
the screen.

 If you apply Quick Edit adjustments to 
a Raw image, you’re asked to save the edited 
version in a different file format, such as JPEG.

FIGURE 3.25 The full-screen review includes 
panels that automatically hide when you’re not 
using them.

Full-Screen Slideshows
The full-screen review feature is good 
even if you’re not reviewing. Use it to play 
quick slideshows, including background 
music and transitions. Click the Play 
button in the control bar (or press the 
spacebar) to start; adjust the settings by 
clicking the Settings button, and choose 
a transition by clicking Theme.

FIGURE 3.26 The full-screen control bar

Toggle 
Filmstrip

Toggle Quick 
Organize 
panel

 
Side-by-
side view

Open 
Settings 
dialog

Toggle 
Quick 
Edit panel

Configure 
slideshow 
transitions

Toggle 
Info panel

Previous, 
Play, 
Next
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40 Chapter 3: Managing Photos in the Organizer

Use Stacks to Organize 
Similar Photos
You’ve spent a day at Yosemite shooting 
picture after picture, and when you return 
home in the evening and download all of 
those photos to your Media Browser, you 
realize you have about a dozen shots of 
the same waterfall—some lit a little dif-
ferently than others, some with different 
zoom settings, but all similar.

Stacks serve as a convenient way to group 
those related photos together. They not 
only save valuable space in the Media 
Browser, they also make assigning tags 
much faster, because tagging a stack 
automatically tags every photo in the 
stack. When you’re ready to take a careful 
look at all of those waterfalls and weed 
out the greats from the not-so-greats, you 
simply expand the stack to view all of the 
stacked photos at once. 

To create a stack:
1. In the Media Browser, select the 

photos you want to include in a stack 
(FIGURE 3.27).

2. Choose Edit > Stack > Stack 
Selected Photos, or press Ctrl+Alt+S/
Command+Option+S.

The photos are stacked together, indi-
cated by a Stack icon in the upper-right 
corner of the top photo in the stack 
(FIGURE 3.28).

To automatically suggest stacks:
1. Select a group of images.

2. Choose Edit > Stack > Automatically 
Suggest Photo Stacks.

3. Click Stack to combine a row of photos 
into a new photo stack (FIGURE 3.29).

FIGURE 3.28 When stacked, the photos occupy 
just one thumbnail and gain the Stack icon.

Stack icon

FIGURE 3.29 Let the Organizer automatically 
suggest stacks.

Stacked

FIGURE 3.27 Select similar photos to organize 
them into a stack.
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Use Stacks to Organize Similar Photos 41

To view all photos in a stack:
1. Choose View > Details to show the 

photos with details visible, if they aren’t 
already. A stack can only be expanded 
when Details is active.

2. Click the arrow icon at the right of the 
stack (FIGURE 3.30). Or, choose Edit > 
Stack > Expand Photos In Stack (press 
Ctrl+Alt+R/Command+Option+R). 
The  photos in the stack appear 
(FIGURE 3.31).

To unstack photos in a stack:
Choose Edit > Stack > Unstack Photos.

The stacked photos return to their original 
locations in the Media Browser.

To flatten a stack:
1. If you’re certain you don’t want any 

photo in a stack except for the top one, 
you can “flatten” the stack and delete 
the others. Choose Edit > Stack > 
 Flatten Stack.

2. In the dialog that appears, click OK to 
delete all of the photos except for the 
top photo in the stack (FIGURE 3.32).

You can also choose to delete the 
associated image files from the disk.

 While you’re viewing the expanded 
stack, you can also remove specific photos 
from a stack or designate a new photo to be 
the top photo (the photo that appears at the 
top of the stack in the Media Browser). Right-
click any stacked photo and then, from the 
context menu, select an option from the Stack 
submenu, such as Set As Top Photo.

FIGURE 3.32 A warning reminds you that you are 
about to delete all but the top photo in your stack.

FIGURE 3.30 When Details is active, the stack’s 
expansion arrow is visible.

FIGURE 3.31 An expanded stack reveals the 
photos that have been grouped together.

VIDEO 3.3

Display and Change 
Information for Photos
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