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118

ANIMATING SYMBOLS 
WITH MOTION TWEENS

Lesson overview
In this lesson, you’ll learn how to do the following:

• Animate the position, scale, and rotation of objects using motion 
tweening.

• Adjust the pacing and timing of your animation.

• Animate transparency and filters.

• Change the path of an object’s motion.

• Create a nested animation.

• Split a motion tween.

• Change the easing of an object’s motion.

• Animate in 3D space.

This lesson will take about 2 hours to complete.

To get the lesson files used in this chapter, download them from the 
web page for this book at www.adobepress.com/AnimateCIB2022. For 
more information, see “Accessing the lesson files and Web Edition” in the 
Getting Started section at the beginning of this book.

3
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Use Adobe Animate to change almost any aspect 
of an object—position, color, transparency, size, 
rotation, and more—over time. Motion tweening is a 
basic technique for creating animation with symbol 
instances.
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120 LESSON 3 Animating Symbols with Motion Tweens

Getting started
Start by viewing the finished movie file to see the animated title page that you’ll cre-
ate in this lesson.

1 Double-click the 03End.mp4 file in the Lesson03/03End folder to play the final 
animation, which was exported as a high-definition video file.

The project is an animated opener that would be placed on a website for an 
imaginary soon-to-be-released motion picture. In this lesson, you’ll use motion 
tweens to animate several components on the page: the cityscape, the main 
actors, several old-fashioned cars, and the main title.

2 Close the 03End.mp4 file.

3 Double-click the 03Start.fla file in the Lesson03/03Start folder to open the initial 
project file in Animate. This file is an ActionScript 3.0 document that is partially 
completed and already contains many of the graphic elements imported into the 
library for you to use. You’ll use all the animation functionality available in an 
ActionScript 3.0 document and then export an MP4 video file.

4 From the view options above the Stage, choose Fit In Window, or choose View 
> Magnification > Fit In Window, so that you can see the entire Stage on your 
computer screen.

5 Choose File > Save As. Name the file 03_workingcopy.fla, and save it in the 
03Start folder.

Saving a working copy ensures that the original start file will be available if you 
want to start over.

 � Note If you have not 
already downloaded 
the project files for 
this lesson to your 
computer from your 
Account page, make 
sure to do so now. See 
“Getting Started” at the 
beginning of the book.
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About animation
Animation is the change of an object’s appearance over time. Animation can be as sim-
ple as moving a ball across the Stage, which is a change in the object’s position. It can 
also be much more complex. As you’ll see in this lesson, you can animate many differ-
ent properties of an object. In addition to an object’s position, you can change its color 
or transparency, change its size or rotation, or even animate the filters that you saw in 
the previous lesson. You also have control over an object’s path of motion and even its 
easing, which is the way an object accelerates or decelerates its property changes.

In Animate, the basic workflow for animation goes like this: Select an object on the 
Stage and choose Create Motion Tween. Move the playhead to a different point in time 
and move the object to a new position or change one of its properties. Animate takes 
care of the rest by smoothly interpolating the changes between the two points in time.

Motion tweens create animation for changes in position on the Stage and for 
changes in size, color, or other attributes. Motion tweens require you to use a 
symbol instance. If the object you’ve selected is not a symbol instance, Animate will 
automatically ask to convert the selection to a symbol.

Animate also automatically separates motion tweens onto their own layers, which 
are called tween layers. There can be only one motion tween per layer, and there can 
be no other element on the layer. Tween layers allow you to change various attri-
butes of your instance at different key points over time. For example, a spaceship 
could be very small on the left side of the Stage at the beginning keyframe and much 
larger at the far-right side of the Stage at an ending keyframe, and the resulting 
tween would make the spaceship both fly across the Stage and slowly grow in size.

Understanding the project file
The 03Start.fla file contains a few of the animated elements already or partially 
completed. Each of the six layers—man, woman, Middle_car, Right_car, footer, and 
ground—contains an animation. The man and woman layers are in a folder called 
actors, and the Middle_car and Right_car layers are in a folder called cars.

 � Note The term 
“tween” comes from 
the world of classic 
animation. Senior 
animators would 
be responsible for 
drawing the beginning 
and ending poses 
for their characters. 
The beginning and 
ending poses were 
the keyframes of the 
animation. Junior 
animators would then 
come in and draw the 
“in-between” frames, or 
do the “in-betweening.” 
Hence, “tweening” 
refers to the smooth 
transitions between 
keyframes.Sam
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122 LESSON 3 Animating Symbols with Motion Tweens

You’ll be adding more layers to create an animated cityscape, refining the animation 
of one of the actors and adding a third car and a 3D title. All the necessary graphic 
elements have been imported into the library. The Stage is set at a standard HD size, 
1280 pixels by 720 pixels, and the Stage color is black. You might need to choose a 
different view option to see the entire Stage.

Animating position
You’ll start this project by animating the cityscape. It will begin slightly lower than 
the top edge of the Stage and then rise slowly until its top is aligned with the top of 
the Stage.

1 Lock all the existing layers so you don’t accidentally modify them. Create a new 
layer above the footer layer and rename it city.

2 Drag the bitmap image called cityBG.jpg from the bitmaps folder in the Library 
panel to the Stage in frame 1 of the city layer.
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3 In the Properties panel, set the value of X to 0 and the value of Y to 90.

This positions the cityscape image just slightly below the top edge of the Stage.

4 Select the cityscape image and choose Create Motion Tween above the timeline, 
or right-click and choose Create Motion Tween, or choose Insert > Create 
Motion Tween.

5 A dialog box appears warning you that your selected object is not a symbol. 
Motion tweens require symbols. Animate asks if you want to convert the 
selection to a symbol so that it can proceed with the motion tween. Click OK.

Animate automatically converts your selection to a symbol, with the default 
name Symbol 1, and stores it in your library. Animate also converts the current 
layer to a tween layer so that you can begin to animate the instance. Tween layers 
are distinguished by a special icon in front of the layer name, and the frames 
are tinted gold in the timeline. The range of frames covered by the tween is the 
tween span. The tween span is represented by all the colored frames from the 

 � Tip Although in this 
task you had Animate 
automatically convert 
your object into a 
symbol for tweening, 
it’s best practice to 
do it yourself before 
animating. That 
way, you control the 
naming and choice of 
the symbol yourself 
and have a better 
understanding of all 
your assets in your 
library.
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124 LESSON 3 Animating Symbols with Motion Tweens

first keyframe to the last keyframe. Tween layers are reserved for motion tweens; 
hence, no drawing is allowed on a tween layer.

6 Move the blue playhead to the end of the tween span, at frame 191.

7 Select the instance of the cityscape on the Stage, and while holding down the 
Shift key, move the instance up the Stage.

Holding down the Shift key constrains the movement to the vertical or 
horizontal direction.

8 For more precision, set the value of Y to 0.0 in the Properties panel.

A small black diamond appears in frame 191 at the end of the tween span. This 
indicates a keyframe at the end of the tween.

Animate smoothly interpolates the change in position from frame 1 to frame 191 
and represents that motion with a motion path on the Stage.

 � Tip Temporarily hide 
all the other layers to 
isolate the cityscape 
and to better see the 
results of the motion 
tween.
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9 Drag the playhead back and forth at the top of the timeline to see the smooth 
motion. You can also choose Control > Play (or press Return/Enter) to make 
Animate play the animation.

Animating changes in position is simple because Animate automatically creates 
keyframes at the points where you move your instance to new positions. If you 
want to have an object move to many different points, simply move the playhead 
to the desired frame and then move the object to its new position. Animate takes 
care of the rest.

Previewing the animation
Integrated into the Timeline panel is a set of playback controls. These controls allow 
you to play, rewind, loop, or go step by step backward or forward through your 
timeline to review your animation in a controlled manner. You can also use the play-
back commands on the Control menu.

1 Click any of the playback buttons on the controller above the timeline to play, 
stop, or step forward or backward one frame. Hold the Step Forward or Step 
Backward button to move the playhead to the last or first frame.

2 Select the Loop button (to the left of the controller), and then click the Play 
button.

The playhead loops, allowing you to see the animation over and over for careful 
analysis.

3 Move the start or end markers in the timeline header to define the range of 
frames that you want to see looped.

The playhead loops within the marked frames. Click the Loop button again to 
turn it off.

Changing the pacing and timing
You can change the duration of the entire tween span or change the timing of the 
animation by dragging keyframes on the timeline.

 � Tip Remove a 
motion tween by 
selecting the tween and 
clicking Remove Tween 
in the Frame tab of the 
Properties panel. You 
can also right-click the 
motion tween on the 
timeline or the Stage 
and choose Remove 
Motion Tween.

 � Tip You can also 
use the Time Scrub tool 
(hidden under the Hand 
tool) to move back and 
forth on the timeline to 
preview your animation. 
Select the Time Scrub 
tool (or hold down 
Spacebar+T) and drag 
left and right on the 
Stage.
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Changing the animation duration
If you want the animation to proceed at a slower pace (and thus take up a much 
longer period of time), you need to lengthen the entire tween span between the 
beginning and end keyframes. If you want to shorten the animation, you need to 
decrease the tween span. Lengthen or shorten a motion tween by dragging its ends 
on the timeline.

1 Move your mouse pointer close to the end of the tween span in the city layer.

Your pointer changes to a double-headed arrow, indicating that you can lengthen 
or shorten the tween span.

2 Drag the end of the tween span back to frame 60.

Your motion tween shortens to 60 frames, reducing the time it takes the 
cityscape to move.
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3 Move your pointer close to the beginning of the tween span (at frame 1).

4 Drag the beginning of the tween span forward to frame 10.

Your motion tween begins at a later time, so it now plays only from frame 10 to 
frame 60.

Adding frames
You’ll want the last keyframe of your motion tween to hold for the remainder of the 
animation. Add frames by Shift-dragging the end of a tween span.

1 Move your pointer close to the end of the tween span.

 � Note If you have 
multiple keyframes in 
a tween, changing the 
length of the tween 
span by dragging 
one end or the other 
will distribute all your 
keyframes uniformly. 
The relative timing 
of events in your 
animation remains the 
same; only the length 
changes.
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2 Hold down the Shift key and drag the end of the tween span forward to frame 
191. Make sure that your tween span is not selected.

The last keyframe in the motion tween remains at frame 60, but Animate adds 
frames through frame 191.

Moving keyframes
If you want to change the pacing of an animation, you can select individual key-
frames and then drag them to new positions.

1 Click the keyframe at frame 60.

The keyframe at frame 60 is selected. Begin dragging the keyframe. A tiny box 
appears next to your mouse pointer, indicating that you can move the keyframe.

 � Tip You can also 
add individual frames 
by choosing Insert > 
Timeline > Frame (F5) 
or remove individual 
frames by choosing Edit 
> Timeline > Remove 
Frames (Shift+F5).
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2 Drag the keyframe to frame 40.

Now, because the last keyframe in the motion tween is reached earlier in the 
animation, the motion of the cityscape proceeds more quickly.

Span-based vs. frame-based  
selection
By default, Animate uses frame-based selection, which means you can select indi-
vidual frames within a motion tween. However, if you prefer to click a motion tween 
and have the entire span (the beginning and end keyframes and all the frames in 
between) be selected, you can enable Span Based Selection from the Frame View 
menu in the upper-right corner of the Timeline panel (or you can Shift-click to select 
the entire span).

With Span Based Selection enabled, you can click anywhere within the motion 
tween to select it, and move the whole animation backward or forward along the 
timeline as a single unit.

If you want to select individual keyframes while Span Based Selection is enabled, 
hold down Command/Ctrl and click a keyframe.
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Moving keyframes vs. changing 
time in tween spans
Managing the timing of your animation by moving keyframes and stretching or 
squashing tween spans can sometimes be frustrating because you will get different 
outcomes depending on what you’ve selected on the timeline and how you drag 
those selections.

If you want to simply move the location of a keyframe within a tween span, make 
sure that only a single keyframe is selected and that the tiny box appears next to 
your pointer as you begin dragging the keyframe to a new location.

If you want to select individual keyframes while Span Based Selection is enabled, 
hold down the Command/Ctrl key and click a keyframe.

Consider the following animation, where a ball moves from the left side of the Stage 
to the bottom edge and then to the right side, making a figure “V.” On the timeline, 
three keyframes mark the three positions of the ball.

Moving the middle keyframe changes the timing of when the ball hits the bottom 
of the Stage.

Keyframe moved
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When you select a span of frames within a tween, you can compress or expand its 
duration by dragging the selection when the double-headed arrow appears near 
the right edge of the selection. A black flag appears indicating when the amount of 
compression or expansion is a multiple of the original length (x0.5, x2, x4, etc.).

Frames compressed (half as much)  
    

Frames expanded (twice as much)

Understanding frame rate
The speed of your animation is tied to the frame rate of your document (shown in 
the Properties section of the Properties panel with the Document tab selected), but 
do not modify the frame rate to change the speed or duration of your animation.

The frame rate determines how many frames on the timeline make up 1 second of 
time. The default is either 30 or 24 frames per second (fps). The seconds are marked 
on the timeline. Frame rate is a measure of how smooth an animation appears—the 
higher the frame rate, the more frames there are to show the action. Animations 
at slower frame rates appear choppy because there are fewer frames to show the 
action. Slow-motion videography depends on very high frame rates to capture 
action that happens very quickly, such as a speeding bullet or a falling water 
droplet.

If you want to modify the overall duration or speed of your animation, don’t change 
the frame rate. Instead, add frames to, or delete frames from, your timeline.

If you want to change the frame rate but keep the overall duration constant, select 
the Scale Spans option in the Properties panel before you modify the frame rate.
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Animating transparency
In the previous lesson, you learned how to change the color effect of any symbol 
instance to change the transparency, tint, or brightness. You can change the color 
effect of an instance in one keyframe and change the value of the color effect in 
another keyframe, and Animate will automatically display a smooth change, just as 
it does with changes in position.

You’ll change the cityscape in the beginning keyframe to be totally transparent but 
keep the cityscape in the ending keyframe opaque. Animate will create a smooth 
fade-in effect.

1 Move the playhead to the first keyframe of the motion tween (frame 10).

2 Select the cityscape instance on the Stage.

3 In the Color Effects section of the Properties panel, choose Alpha from the Style 
menu.

4 Set the Alpha value to 0%.

The cityscape instance on the Stage becomes totally transparent, but you can still 
see the blue bounding box around it.Sam

ple
 p

ag
es



ADOBE ANIMATE CC CLASSROOM IN A BOOK (2022 RELEASE) 133

5 Move the playhead to the last keyframe of the motion tween (frame 40).

6 Make sure that the cityscape instance on the Stage is still selected.

7 In the Properties panel, in the Color Effects section, set the Alpha value to 100%.

The cityscape instance on the Stage becomes totally opaque.

8 Preview the effect by choosing Control > Play (or pressing Return/Enter).

Animate interpolates the changes in both position and transparency between the 
two keyframes.

Animating filters
Filters, which give instances special effects such as blurs and drop shadows, can also 
be animated. You’ll next refine the motion tween of the actors by applying a blur 
filter to one of them to make it appear as if the camera changes focus. Animating 
filters is no different from animating changes in position or changes in color effect. 
You simply set the values for a filter at one keyframe and set different values for the 
filter at another keyframe, and Animate creates a smooth transition.

1 Make sure that the actors layer folder on the timeline is visible.

2 Unlock the woman layer.

 � Note Filters can 
be applied, but not 
animated, in an HTML5 
Canvas document.
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3 Move the playhead to the beginning keyframe of the motion tween in the woman 
layer, at frame 23.

4 Select the instance of the woman on the Stage. You won’t be able to see her 
because she has an alpha value of 0% (totally transparent). Click the upper-
right side of the Stage to select the transparent instance. Or click frame 23 in 
the woman layer in the timeline to highlight it, then click the Object tab in the 
Properties panel.

5 In the Properties panel, click the Add Filter (+) button in the Filters section, and 
choose Blur from the menu to add a blur to the instance.
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6 In the Filters section of the Properties panel, select the link icon to apply equal 
values to the x and y directions if it isn’t already selected. Set the Blur X value 
to 20 pixels.

The Blur Y value also changes to 20 pixels.

7 Move the playhead along the entire timeline to preview the animation.

The woman instance is blurred throughout the motion tween.

8 Select frame 140 in the woman layer and choose Insert Keyframe above the 
timeline.

Animate establishes a keyframe at frame 140.

9 Select frame 160 of the woman layer and choose Insert Keyframe above the 
timeline to add another keyframe.

Sam
ple

 p
ag

es



136 LESSON 3 Animating Symbols with Motion Tweens

10 Select the Object tab of the Properties panel.

11 In the Properties panel, change the value of the Blur filter to X=0 and Y=0.

The Blur filter changes from the keyframe at frame 140 to the keyframe at 160. 
Animate creates a smooth transition from a blurry instance to an in-focus 
instance.

Understanding property keyframes
Changes in properties are independent of one another and do not need to be tied 
to the same keyframes. That is, you can have a keyframe for position, a different 
keyframe for the color effect, and yet another keyframe for a filter. Managing many 
different kinds of keyframes can become overwhelming, especially if you want dif-
ferent properties to change at different times during the motion tween. Fortunately, 
Animate provides a few helpful tools for keyframe management.

When viewing the tween span, you can choose to view the keyframes of only cer-
tain properties. For example, you can choose to view only the Position keyframes so 
that you can see when your object moves. Or you can choose to view only the Filter 
keyframes so that you can see when a filter changes. Right-click a motion tween in 
the timeline, choose View Keyframes, and then choose the desired property from 
the list. You can also choose All or None to see all the properties or none of the 
properties.

 � Tip Click the Enable 
or Disable Filter button 
in the Filters section of 
the Properties panel to 
toggle the visibility of 
the filter effect on your 
animation to make your 
work easier. The Enable 
or Disable Filter option 
doesn’t affect the final 
exported animation, 
however.

 � Tip You can add 
more than one filter 
to an animation. Drag 
the filters to rearrange 
the order in which they 
appear in the Properties 
panel, or collapse each 
filter to save space in 
the panel.
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