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376

EXPLORING NEURAL FILTERS

Lesson overview
In this lesson, you’ll learn how to do the following: 

• Understand how Neural Filters are different than other filters and 
effects in Photoshop.

• Explore the Neural Filters workspace.

• Apply a Neural Filter to an image.

• Combine multiple Neural Filters in a single layer or document. 

This lesson will take about 30 minutes to complete. To get the lesson 
files used in this chapter, download them from the web page for this 
book at adobepress.com/PhotoshopCIB2023. For more information, 
see “Accessing the lesson files and Web Edition” in the Getting Started 
section at the beginning of this book.

As you work on this lesson, you’ll preserve the start files. If you need 
to restore the start files, download them from your Account page.

15
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Neural Filters are advanced fi lters trained using 
machine learning. You can explore ideas that would 
be more labor-intensive, or sometimes impossible, 
with conventional digital photo fi lters and eff ects.

PROJECT: COMPOSITING WITH NEURAL FILTERSPROJECT: COMPOSITING WITH NEURAL FILTERS Landscape: © Jurik Peter, Shutterstock; superhero: © sunlight19, Shutterstock
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Understanding Neural Filters
If you worked through the earlier lessons in this book, you’ve used Photoshop filters 
such as Surface Blur, Smart Sharpen, Clouds, and Liquify. Those are conventional 
filters that produce their results with algorithms—procedural programs where the 
code itself determines the result.

The newer Neural Filters produce results in a different way, combining traditional 
algorithms with machine learning and other advanced techniques. Machine learning 
means that a filter in Neural Filters can be trained using many examples of desir­
able and undesirable results, potentially creating better images than what could be 
achieved with procedural computer code alone.

Neural Filters are different from other Photoshop effects in the following ways:

• Neural Filters are trained by machine learning and neural networks.

• Some filters need to be downloaded before the first time you use them. This is 
partly to save space on your computer, because some Neural Filters and their 
machine­learning models can be large. If you need to download a Neural Filter, 
you can do it with one click in the Neural Filters workspace.

• Some filters display a message saying that they process image data in the cloud 
(on Adobe Creative Cloud servers). They may need more power than a desktop 
computer has, or a machine­learning model may be too large to download.

It’s possible to use some Neural Filters without an Internet connection, but you get 
the most options when your computer is connected to the Internet.

Getting started
Exploring the possibilities of Neural Filters might turn out to be the most fun you 
have with this book. Let’s first take a look at the files you’ll work with.

1 Start Photoshop, and then simultaneously hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (macOS) to restore the default preferences. (See 
“Restoring default preferences” on page 5.)

2 When prompted, click Yes to delete the Adobe Photoshop Settings file.

3 Choose File > Browse In Bridge to open Adobe Bridge.

4 In Bridge, click Lessons in the Favorites panel. Double­click the Lesson15 folder 
in the Content panel. 

5 Compare the files 15Restore.psd and 15Restore_End.psd, 15Colorize.psd and 
15Colorize_End.psd, and 15Composite.psd and 15Composite_End.psd. Using 
Neural Filters, you’ll create the finished files in just a few clicks.

•Note: You can use 
Neural Filters if your 
computer meets the 
system requirements 
for Photoshop, but 
performance is better 
with a more powerful 
CPU, more powerful 
graphics hardware, and 
in some cases a faster 
Internet connection.

•Note: If Bridge 
isn’t installed, the 
File > Browse In Bridge 
command in Photoshop 
will start the Creative 
Cloud desktop app, 
which will download 
and install Bridge. After 
installation completes, 
you can start Bridge. 
For more information, 
see page 3.
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Exploring the Neural Filters workspace
1 In Bridge, double­click the 15Restore.psd file to open it in Photoshop. If the 

Embedded Profile Mismatch dialog box appears, click OK.

2 Save the document as 15Restore_Working.psd in the Lesson15 folder.

3 Choose Filter > Neural Filters.

In the Neural Filters workspace, the image appears in a large preview area on the 
left, and the Neural Filters panel is on the right:

• When you select a filter, its options appear in the Neural Filters panel.

• To use a filter, it must be enabled. A filter is enabled when its toggle switch is 
moved to the right position and in color. You can enable multiple filters.

• If the selected filter recognizes faces in the image, they’re listed in the thumbnail 
preview menu at the top of the options. In the document, a blue rectangle 
indicates the selected face; gray rectangles indicate other detected faces. Select a 
face in the face menu or in the document.

• To compare the current filter results with the original image, click the Show 
Original icon at the bottom of the workspace to select it and display the original 
layer. Click again to deselect it and preview the filter results again. 

• When a document has multiple layers, the Layer Preview button controls 
whether the preview displays one layer or the entire document.

• Along the left side, the top two tools let you paint a mask to hide filter effects 
from some areas, similar to the layer masks you edited in Chapters 6 and 8.

K L M

I

J

B
C

D E F G H

A

•Note: If Photoshop 
displays a dialog box 
telling you about the 
difference between 
saving to Cloud 
Documents and 
On Your Computer, click 
Save On Your Computer. 
You can also select 
Don’t Show Again, 
but that setting will 
deselect after you reset 
Photoshop preferences.

•Note: If the Neural 
Filters command is not 
available, make sure a 
visible layer is selected.

A. Add To Selection and Subtract From 
Selection tools

B. Hand tool

C. Zoom tool

D. Selected face

E. Filter lists

F. Filter toggle, enabled

G. Use Graphics Processor (GPU) option

H. Thumbnail menu for selecting a 
detected subject, such as a face

I. Reset filter options to default settings

J. Options for the selected Neural Filter

K. Show Original/Preview Changes 
button

L. Show current layer or all layers 
(Layer Preview)

M. Output options
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380 LESSON 15 Exploring Neural Filters

Restoring an antique portrait photo
To learn more about Neural Filters, let’s see how they can help restore old photos.

1 In the filters list, scroll down to the Restoration category, and click the toggle 
switch next to the Photo Restoration filter to enable and apply it. (If options 
are not available and a Download button appears instead, click the Download 
button because it means the filter is not yet installed. When the download 
completes, the filter will install itself and be ready for you to use.)

A

B

C

2 To compare the changes with the original, click the Show Original button at the 
bottom of the workspace. Click once to hide the changes and see the original, 
and click again to preview the changes again. If you don’t notice a change, zoom 
in to 100% or higher magnification.

3 As needed, adjust the first two Photo Restoration options, and then repeat step 2 
to check your work:

• We left Photo Enhancement at its default value of 50.

• We reduced Enhance Face to 15 to preserve more of the original film texture.

4 Scroll up or zoom out as needed until you can see the top of the image. That part 
of the photo print is scratched and torn.

•Note: Adobe 
may update Neural 
Filters after this book 
is published, so the 
list of categories and 
filters you see may 
depend on the version 
of Photoshop you are 
using. Also, if Adobe 
updates how Neural 
Filters effects are 
trained, you may see 
different results than 
those in this chapter.

A. Photo Enhancement

B. Enhance Face

C. Scratch Reduction

•Note: Some 
Neural Filters may be 
labeled Beta, which 
means they function 
but are still under 
development. You can 
use them, but when 
the finished version is 
released, those filters 
may produce different 
results or some options 
may be different.
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5 Adjust Scratch Reduction to about 20. A progress bar at the bottom of the 
image may indicate that it will take a little while. When it’s done, the scratch is 
intelligently removed, which you can verify using the Show Original button.

6 You greatly improved this image using the Restoration Neural Filter. For Output, 
choose Smart Filter, and then click OK to exit Neural Filters. Close the document, 
saving your changes.

Adding color and depth blur
You can use Neural Filters to colorize black­and­white images and add depth blur.

1 In Bridge, double­click the 15Colorize.psd file to open it in Photoshop. If the 
Embedded Profile Mismatch dialog box appears, click OK.

2 Save the document as 15Colorize_Working.psd in the Lesson15 folder.

3 Choose Filter > Neural Filters.

4 In the filters list, scroll down to the Color category, and click the toggle switch 
next to the Colorize filter to enable it. Make sure Auto Color Image is selected.

The Colorize filter applies assumed colors to objects and regions it recognizes, such 
as the leaves on the tree and the boy’s skin and clothing. If you disagree with a color 
choice Colorize made (for example, if the shirt is not all the same color), you can 
apply custom colors to specific areas.

▶Tip: If you increase 
the value of a Neural 
Filter option, watch 
out for negative 
side effects on some 
parts of the image. 
it’s typically better to 
leave minor spots and 
wrinkles, cleaning them 
up quickly using the 
retouching techniques 
you learned in Lesson 2.

•Note:  If the Colorize 
options aren’t available 
because the filter needs 
to be downloaded, 
download it.

▶Tip: For a different 
look, select a Profile. If 
the result is too strong, 
reduce the Profile 
Strength, and make 
any other changes you 
like using the other 
Adjustments options.
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5 In the preview image on the right, click to add a new color focal point over an 
area you want to change, and set its color using the color picker below the image. 
Repeat for other areas where you want to change the color.

6 In the Photography category in the filters list, click the toggle switch next to the 
Depth Blur filter to enable it (download it if needed).

7 Adjust filter options as needed until you like the result. We disabled the Focus 
Subject option because it included part of the tree, and we set our Focal Range 
to 40 so that more of the bicycle remains in focus.

8 You’ve brought this image back to life! For Output, choose Smart Filter, and then 
click OK to exit Neural Filters. Close the document, saving your changes.

▶Tip: If the results 
of the Colorize filter 
aren’t perfect, you can 
combine it with manual 
Photoshop techniques. 
For example, after 
closing Neural Filters, 
add a new layer that 
uses the Color blending 
mode, and paint on that 
layer to colorize the 
image under it.
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About Output options 
in Neural Filters
A Neural Filter may provide several options for applying fi lter results to the docu-
ment, in the Output menu. The number of options you see may be diff erent than 
in the fi gure below, depending on which fi lter and fi lter options are selected. Your 
choice aff ects the amount of editing fl exibility you have later.

Current Layer applies the result to the selected layer. This permanently alters the 
original layer. The only way to back out of it is to undo it before you close and save 
the document. We recommend using one of the following options instead, because 
they leave the current layer intact.

New Layer applies the result to a full copy of the selected layer, leaving that original 
unchanged.

New Layer Masked applies the result to a copy of the selected layer with the 
changed areas showing through a layer mask. This helps ensure that areas of the 
image that were not supposed to be changed remain as they are on the original layer.

Smart Filter applies the result to a Smart Object created from the selected layer. 
You can edit the fi lter settings later by double-clicking that layer’s Neural Filters 
instance in the Layers panel.

New Document applies the result to a duplicate document containing the fi lter 
results on one layer.

The choice you make can depend on the balance you want between fl exibility and 
fi le size. Additional layers and Smart Objects provide more editing freedom, but 
tend to create larger fi le sizes.

When you make multiple edits within a fi lter, such as changing multiple faces dif-
ferently in a group portrait, all changes are included in the output. For example, if 
you apply Smart Portrait and Style Transfer to the same layer, all of those results are 
applied to a single layer or Smart Filter.

Neural Filters might not produce perfect results right away. By applying Neural 
Filters results as a separate masked layer, you can freely blend them with the original 
layer to achieve a more convincing result, while still saving many steps compared to 
traditional, more labor-intensive methods.
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Creating a more convincing composite
When compositing multiple images, the images may not be consistent in tone and 
color. Some Neural Filters can help resolve this.

1 In Bridge, double­click the 15Composite.psd to open it in Photoshop. If the 
Embedded Profile Mismatch dialog box appears, click OK.

2 Save the document as 15Composite_Working.psd in the Lesson15 folder. 
Click OK in the Photoshop Format Options dialog. This image will become a 
thumbnail image for a video, but the color palette and subject need to be closer 
to the look of the art director’s concept. 

3 In the Layers panel, make sure the Planet layer is selected, and then choose 
Filter > Neural Filters.

4 In the filters list, scroll down to the Creative category, and click to enable the 
toggle switch next to the Landscape Mixer filter (if needed, download it first). 
The Landscape Mixer filter can apply the look of one landscape image to 
another. Depending on the landscape images you mix, you can even change a 
scene from summer to winter or fill a desert image with green foliage.

5  In the Landscape Mixer options, click different Presets to experiment with how 
each of them alters the landscape attributes of the layer.

6 Click the third preset. That’s the one to use for this project.

7 For Output, choose Smart Filter, and then click OK to apply the changes.

8 In the Layers panel, click the eye icon for the Heroine layer to make it visible. Its 
tone and color doesn’t quite match up with the landscape, so let’s improve that.

▶Tip: You can use 
your own image to 
drive the style applied 
by Landscape Mixer. 
Click Custom, click 
Select An Image, and 
open an image from 
your computer. Also, 
Landscape Mixer 
options let you adjust 
attributes such as the 
amount of Day or Night 
and the time of year. For 
example, you can add 
snow by increasing the 
Winter value.
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9  With the Heroine layer selected, choose Filter > Neural Filters, and in the 
Color category in the fi lters list, click to enable the toggle switch next to the 
Harmonization fi lter (if needed, download it fi rst). Th e Harmonization fi lter 
helps match the color and tone of a layer to another layer in the document.

1 0  In the Reference Image section, click Select A Layer, and select Planet.

Th e color and tone of the Heroine layer change to better match the color and light 
of the Planet layer, but it could be improved.

1 1 In the Harmonization options, drag the Cyan/Red slider about one­third of 
the way toward Red, drag Saturation to about +15, and reduce Brightness 
to about –30. Make any other adjustments that make the composite more 
convincing. Remember to use the Show Original button to check your work.

1 2  For Output, choose Smart Filter, and then click OK to apply the changes.

▶ Tip: The best thing 
you can do to make 
your composite images 
the most convincing 
is to make sure all of 
your original images are 
consistent in as many 
ways as possible—not 
only color and tone, but 
other visual details such 
as the quality of lighting 
(including sources, 
angles, and shadows), 
lens focal length, and 
camera distance from 
the ground.Sam
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1 3 In the Layers panel, click the eye icon for the Guardian type layer to make it visible.

You’ve completed the video thumbnail … nice work! You used Neural Filters to 
transform the look of both images in just a few steps, making them work together to 
match the mood and the look of the production.

1 4 Save your work, and close the document.

You’ve learned the basics of using Neural Filters. The results created in this lesson 
required only a few steps each; for example, retouching the old images was almost 
no work compared to the steps you learned in Lesson 2 and Lesson 5.

You’re ready to explore the possibilities of the Neural Filters with your own images!

▶Tip: Neural Filters 
results might not 
always produce perfect 
results right away. But 
remember that you 
can output the results 
to a separate masked 
layer, so you can blend 
them with the original 
layer to achieve a more 
convincing result, 
still saving many 
steps compared to 
more labor-intensive 
methods.
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Finding the filter or effect you want
It can be a challenge to find the right filter or effect, because Photoshop offers 
them in multiple places in the workspace and menus, and some filters are similar to 
others. Here is a quick guide to the places to find filters and effects in Photoshop:

General filters are on the Filter menu and its submenus. Not every filter is visible on 
the submenus, so also remember to look inside the next two filter galleries.

Filter Gallery (Filter > Filter Gallery) offers many conventional (algorithmic) filters, 
such as Diffuse Glow and Mosaic Tiles. These are mostly intended for creative effects.

Neural Filters (Filter > Neural Filters) offer filters trained by machine learning. They 
can produce results that are better than, or not possible with, conventional filters.

To explore all your options, keep those multiple filter locations in mind. For example, 
if you want to improve skin complexion, you can use the more traditional multistep 
technique in Lesson 12 that uses the Surface Blur filter, compare that to the results 
you get from using the one-step Skin Smoothing filter in Neural Filters, and choose 
the result you think is better for a specific image.

Layer styles are nondestructive, easy ways to apply drop shadows, glows, and other 
effects you have tried in this book. You can find them by clicking the fx button at the 
bottom of the Layers panel or on the Layer > Layer Style submenu.

As you have practiced in this book, even a destructive filter (permanently altering 
layer pixels) can be applied nondestructively (allowing edits or removal later) if 
the layer is a Smart Object. You can prepare a selected layer for nondestructive filter-
ing by first choosing Filter > Convert For Smart Filters.

To combine filters on a layer, you can typically apply each filter in turn. In a filter gal-
lery dialog box or workspace (Filter Gallery, Neural Filters, and Blur Gallery), you can 
combine multiple filters before you exit the dialog box or workspace.
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 Neural Filters gallery
In addition to the Neural Filters you try in the lesson, this gallery shows examples of other Neural Filters included 
with Photoshop. Some are useful for restoring and correcting images; others are fun ways to explore creatively. 
Adobe may update or change the available Neural Filters, so the exact list of Neural Filters in Photoshop may 
depend on the version installed on your computer.

Smart Portrait lets you tune details of portraits 
such as emotions, facial expressions, facial age, and 
gestures such as which way the eyes are looking. In 
this example, the head was turned slightly forward.

Super Zoom is a convenient way to enlarge part of 
a photo to use as a portrait. For example, you can 
pick out one person in a group photo and create an 
enhanced, sharpened enlargement for a profi le pic-
ture. Or, if a person’s face is too small in the middle 
of a smartphone photo, you can fi ll more of the 
frame with their face. Unlike many scaling methods, 
Super Zoom off ers detail enhancement, noise reduc-
tion, and JPEG artifact removal powered by machine 
learning. Super Zoom is optimized for portraits, but 
you can try it with other types of subjects.

Skin Smoothing can reduce acne, blemishes, and 
other skin irregularities, while preserving the overall 
character of the skin, and maintaining the sharpness 
of facial features such as eyes.

Before BeforeAfter

Super Zoom, 3x

After

Image © mangostock. Shutterstock
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JPEG Artifacts Removal helps reduce unsightly 
side eff ects produced by applying JPEG image 
compression at a low quality setting. JPEG artifacts 
are typically seen as banding or blocks in areas that 
should be smooth. Although it’s always better to 
use the highest quality version of an image, JPEG 
Artifacts Removal might save the day when a low-
quality JPEG image is all that’s available to you.

Style Transfer lets you apply the artistic style of 
one image to another image. You can choose from 
a range of Artist Styles presets and then customize 
the look further using the fi lter’s options.  You can 
even apply your own style by clicking the Custom 
tab and selecting an image from your computer.

Before

Before

After

After
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Improving Photoshop with 
your usage data and images
An important way that software developers improve features based on machine 
learning is to train them using examples of good results and bad results. Any com-
pany that uses machine learning needs a way to train the models that their software 
uses, ideally using examples that represent the interests of the customers of the 
software. But many software developers don’t have very large data sets of actual 
customer files, and even if they store customer files in the cloud, they typically do 
not have customers’ permission to use their files to train software.

To make it easier to improve Photoshop, Adobe added a Product Improvement 
pane to the Preferences dialog box in Photoshop. The purpose of the Photoshop 
Improvement Program is to request permission to use your images and usage data 
to help improve Photoshop features; this is not necessarily limited to machine learn-
ing. The “Yes, I’d like to participate” option is disabled by default, but if you want to 
participate, you can enable it. When it’s enabled, Adobe researchers may collect 
usage data, cloud documents, and other images you edit in Photoshop.

Whether or not you participate in the Photoshop Improvement Program is partly a 
personal decision. You may want to participate if you think your usage data might 
help improve how well Photoshop handles the kinds of image editing that you do.

However, if you work for a company or organization that handles confidential 
documents, if you need to protect the privacy or proprietary data of your clients, or 
if you are legally bound by nondisclosure agreements, you should be aware of the 
potential consequences of participating in the Photoshop Improvement Program.

For more information about how your usage information is handled, see the Adobe 
Product Improvement Program web page at adobe.com/privacy/apip.html.
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Review questions
1 How does a filter in Neural Filters differ from other filters in Photoshop?

2 How does an Internet connection affect how you use Neural Filters?

3 Why is it typically best to choose any Neural Filters output option except Current 
Layer?

4 How can Neural Filters help restore digitized images of old prints and slides?

5 How can Neural Filters help with compositing multiple images?

Review answers
1 Neural Filters are trained using machine learning, so they are capable of results that are 

not attainable using conventional algorithmic filters.

2 If you are connected to the Internet, you can download Neural Filters and use Neural 
Filters that process image data in the cloud. If you choose to participate in the 
Photoshop Improvement Program, an Internet connection allows your usage data and 
images to be sent to Adobe for use by researchers.

3 The Current Layer option applies the results of Neural Filters to the selected layer, 
permanently changing it (destructive editing). The other Output options apply the 
results of Neural Filters to a separate layer or as a Smart Filter, maintaining a layer’s 
original state, so that you can start over at any time (nondestructive editing).

4 The Photo Restoration Neural Filters (and possibly Super Zoom) can help improve 
the quality of digitized images of old prints and slides. The Colorize Neural Filter can 
re­create colors for a black­and­white photo. JPEG Artifacts Removal can improve 
images that were saved at a low­squality JPEG compression setting. Depth Blur can 
help focus attention on the subject of a photo. 

5 Neural Filters such as Landscape Mixer, Harmonization, and Color Transfer can help 
unify a composite by making its layers more visually consistent with each other.Sam
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